Closed Bug 1394377 Opened 2 years ago Closed 2 years ago

Increase shutdown timeout for Marionette client from 65s to 120s

Categories

(Testing :: Marionette, enhancement)

57 Branch
enhancement
Not set

Tracking

(firefox56 fixed, firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The currently used shutdown timeout is too short and as such (especially for debug builds) the background hang monitor is not able to kill Firefox due to a long hanging thread during shutdown.

As result we do not get any information why a shutdown has been taken that long. See bug 1385605 or others for example.

Given that the current shutdown hangs are all caused by sessionrestore tests, I would assume it's related to this component. Maybe its just bug 1387222 as I have seen on bug 1385605.
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Attachment #8901865 - Flags: review?(mjzffr)
Attachment #8901865 - Flags: review?(dburns)
Comment on attachment 8901865 [details]
Bug 1394377 - Increase default shutdown timeout to 120s.

https://reviewboard.mozilla.org/r/173294/#review179022
Attachment #8901865 - Flags: review?(mjzffr) → review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f85951d982ab
Increase default shutdown timeout to 120s. r=maja_zf
https://hg.mozilla.org/mozilla-central/rev/f85951d982ab
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Comment on attachment 8901865 [details]
Bug 1394377 - Increase default shutdown timeout to 120s.

https://reviewboard.mozilla.org/r/173294/#review179232
Attachment #8901865 - Flags: review?(dburns) → review+
The change works like expected and we do no longer force kill Firefox before the background hang monitor kicks in. Lets uplift this test-only patch to beta too. Thanks.
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.