Closed Bug 1394426 Opened 2 years ago Closed 2 years ago

Category names aren't displayed on the navigation bar when changing the Width to 830

Categories

(Firefox :: Preferences, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- affected

People

(Reporter: hani.yacoub, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image 830.png
[Affected versions]: 
Nightly 57.0a1

[Affected platforms]:
Platforms: Windows 10 x 64 and Ubuntu 16.04 x64 and Mac OS X 10.12.

[Steps to reproduce]:
1. Launch Firefox.
2. Go to "about:preferences".
3. Change the W to 830.

[Expected result]:
According to the spec category name should be displayed in navigation bar.

[Actual result]:
Category names aren't displayed on the navigation bar when changing the Width to 830.
Blocks: 1357306
Whiteboard: [photon-preference][triage]
I think it's because visual spec is vague and ambiguous as regards the RWD breaks.

In page [1], navigation should be icon only in W830.
In page [2], navigation is still showing icon + text in W830.

I've confirmed that the current implementation will adjust the navigation (hide text) as soon as the width reaches 830px.

Hani, I'm going to close this issue due to spec issue. Note that you might find the real situation will be slightly different with spec across platforms because of extra scrollbar. For instance, Windows has an obvious scrollbar which will affect the content width, so I think it's okay to ignore this kind of issue. 


Helen, can you help us fix the visual spec? Thanks

[1] https://mozilla.invisionapp.com/share/X8BGCX9PD#/screens/245153107
[2] https://mozilla.invisionapp.com/share/X8BGCX9PD#/screens/249287448
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(hhuang)
Resolution: --- → INVALID
remove whiteboard tag due to its INVALID
Whiteboard: [photon-preference][triage]
Per discussion with Helen, the visual spec is correct and W830 is the break point to hide the navigation text. However, from the visual designer's point of view, this is a minor and ignorable issue due to merely 1px difference. (Ideally, the text should be hide in W829px rather than W830px). As a result, it shouldn't be an issue. Thanks
Flags: needinfo?(hhuang)
You need to log in before you can comment on or make changes to this bug.