UW IMAP: Cannot delete a mail Folder in IMAP.

VERIFIED DUPLICATE of bug 119630

Status

MailNews Core
Networking: IMAP
VERIFIED DUPLICATE of bug 119630
16 years ago
9 years ago

People

(Reporter: Matt Roca, Assigned: Scott MacGregor)

Tracking

({imap-interop})

Trunk
x86
Windows 2000
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Get error message:  "The current command did not succeed.  The mail server 
responded: RENAME failed: Can't create mailbox node /home/meroca/Mail/Trash/: 
File exists."

On the server-side, we are using the standard U-Washington IMAP server, and we 
are able to delete folders on many different IMAP clients, including Outlook 
Express, Eudora, PINE, and Pegasus.

Comment 1

16 years ago
What is your IMAP server directly? Can you attach a screen shot of your Advanced 
IMAP Server Settings info here? Thanks.
Or, are you trying to delete a folder name which already existing in Trash 
folder?
Keywords: interop
Summary: Cannot delete a mail Folder in IMAP. → UW IMAP: Cannot delete a mail Folder in IMAP.
(Reporter)

Comment 2

16 years ago
I am using the IMAP standard server from Washington University, the people that
created the IMAP protocol. (http://www.washington.edu/imap/).
ftp://ftp.cac.washington.edu/imap/imap-2001a.tar.Z

There is no "Advanced IMAP Server Settings".  This is a standard compile of the
UWashington IMAP server.

Basically, if you create a "mailbox" called "Trash", you are creating a standard
file on the unix IMAP server which can contain messages.  A mailbox/file cannot
contain another mailbox, and cannot contain sub-folders.  If you create a
containing folder by naming the folder "folder-container/", the folder cannot
contain messages, it can only contain other mailboxes.
(Reporter)

Comment 4

16 years ago
There appears to be a fix for this..  If you go into Mail & News Account
Settings, under Server Settings: Advanced, uncheck the "Server supports folders
that contain sub-folders and messages".  Deleting folders will then work
properly.  Suggest making that option 'off' by default.
Marking this as a duplicate. If you thaink that's an error, please reopen.

*** This bug has been marked as a duplicate of 119630 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.