[nosdk] Stop using EventEmitter.decorate in TabActor

RESOLVED DUPLICATE of bug 1450956

Status

P3
normal
RESOLVED DUPLICATE of bug 1450956
a year ago
7 months ago

People

(Reporter: jdescottes, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified

Firefox Tracking Flags

(firefox57 fix-optional)

Details

(Whiteboard: [reserve-nosdk])

Follow up to Bug 1391562.

Migrate TabActor in devtools/server/actors/tab.js to use ES6 classes and remove the use of EventEmitter.decorate introduced in Bug 1391562. Instead we should use ES6 inheritance for the TabActor.

> class TabActor extends EventEmitter { ... }

The TabActor prototype is not straightforward to migrate which is why this has been moved to a followup.
status-firefox57: --- → fix-optional
Blocks: 1402840
No longer blocks: 1391562
As protocol.js inherits from EventEmitter, this will be resolved in 1450956
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1450956

Updated

7 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.