Display ALT in IMG tag as tooltip

VERIFIED DUPLICATE of bug 25537

Status

SeaMonkey
General
--
enhancement
VERIFIED DUPLICATE of bug 25537
16 years ago
13 years ago

People

(Reporter: msgport, Assigned: Matti)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020421
BuildID:    2002042108

Suggestion to display the ALT text for IMG as tooltip. There is also a minor
problem that I don't know whether it is a feature or a bug. Say some tooltip
text that has two lines or more, mozilla will display them in one line and
truncate if it is too long.

To Reproduce:
<a href="any.html" title="Line 1
Line 2">Link</a>

IE will display it as a multi-line tooltip while mozilla will display it as one
line only.

Comment 1

16 years ago
The ALT-tag-as-tooltip part is bug 25537, marking DUPLICATE.

Regarding multiline tooltips: the title attribute is of type CDATA. 
The HTML4 standard says about CDATA
<http://www.w3.org/TR/REC-html40/types.html#type-cdata>:
"User agents should interpret attribute values as follows:
 [...]
 * Ignore line feeds"

Hence, this part of the bug is INVALID.


Reporter, for future reference: only report one bug per report.

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.