Closed Bug 1395237 Opened 2 years ago Closed 2 years ago

Update webrender to 81cba6b139c4c1061cab6a1c38acf2ae7f50445d

Categories

(Core :: Graphics: WebRender, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [gfx-noted])

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1394394 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ 44a60041337b1716b1f2264924cea8d86f88152c

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8117e084974aed357726c030ef275cddb1479828
https://treeherder.mozilla.org/#/jobs?repo=try&revision=497a58a01aa28edaad032bcb39b3287c0cc53dc7

R4 failure, but it's a good thing - the fuzz has gone down from (4, 3320) to (4, 83).

Fix range:
* 44a60041 Auto merge of #1635 - glennw:opt-bs, r=kvark
* f1569c04 Switch box shadows to render to A8 cache instead of RGBA8.
WR @ 1e12498cdcfc583e2d817767ad9d894cf925e407

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9db6b0e50709ccede5e53e295daa6663be5e3192
https://treeherder.mozilla.org/#/jobs?repo=try&revision=eec120b3e8efa42ebb9e17194ea3907778b25afb

Green

WR @ 3ed45912267d6be0efb2a95e07f43c7191070a17

https://treeherder.mozilla.org/#/jobs?repo=try&revision=0b8cc193077a5ce6b736e85d9fed9e2f8c12ca8f
https://treeherder.mozilla.org/#/jobs?repo=try&revision=dd67a33522656c753125261f9b1de8683396ee33

Bustage. Regression range:

*   3ed45912 Auto merge of #1638 - glennw:fix-tc-profile, r=nical
|\
| * da0b2138 Fix texture cache profiler display.
*   94230449 Auto merge of #1636 - glennw:debugger-docs, r=nical
|\
| * f33bde70 Add a basic display list treeview to the debugger.
*   f6e95d02 Auto merge of #1643 - glennw:shader-tidy-1, r=nical
|\
| * 0dfd6f38 Shader tidy up 1/n.
|/
*   eee6067b Auto merge of #1639 - kvark:gl-pbo, r=glennw
|\
| * 7487325e Make sure no PBO is bound on texture deletion
* adba8e64 Auto merge of #1602 - lsalzman:font-instance-key, r=glennw
* 5d3c7c36 Add font instance keys which associate size and other options with a key

The bustage looks like it's related to the fonts API so presumably Lee's patch in bug 1393055 will fix it. I'll add it to my queue.
WR @ 81cba6b139c4c1061cab6a1c38acf2ae7f50445d

https://treeherder.mozilla.org/#/jobs?repo=try&revision=10b9aabef663406617674bef1baab7d6c3c02770
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7a8c9f202c5a2cbf45376582c26b00b2f9d16704

Still busted. Looks like from the bytes_per_pixel change in da0b2138 (servo/webrender#1638). I left a comment there.
You should be able to fix this one by removing the .unwrap() call after bytes_per_pixel() (and it looks like we only call bytes_per_pixel once in the bindings).
Yeah, the fix is trivial. My point is more so that people are still landing changes in WR without testing that it doesn't break gecko. I think the burden of testing gecko is still too high - we need a more automated solution for this problem.
WR @ 81cba6b139c4c1061cab6a1c38acf2ae7f50445d, with the fix:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=eaaee9ac632188277b89d263747e7d8c647046f6
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f3be63e54863ec7d6adbacb79e8b94ac6d88204a

Green so far. If this is clean I'll probably land it to avoid the font patches from rotting too much or constantly needing a rebase.
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 81cba6b139c4c1061cab6a1c38acf2ae7f50445d
Version: unspecified → 57 Branch
Comment on attachment 8903217 [details]
Bug 1395237 - Fix for change in WR cset da0b2138.

https://reviewboard.mozilla.org/r/175000/#review180090
Attachment #8903217 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8903216 [details]
Bug 1395237 - Update reftest fuzz values as a result of WR cset f1569c04.

https://reviewboard.mozilla.org/r/174998/#review180092
Attachment #8903216 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8903215 [details]
Bug 1395237 - Update webrender to commit 81cba6b139c4c1061cab6a1c38acf2ae7f50445d.

https://reviewboard.mozilla.org/r/174996/#review180094
Attachment #8903215 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ad188215f64d
Update webrender to commit 81cba6b139c4c1061cab6a1c38acf2ae7f50445d. r=jrmuizel
https://hg.mozilla.org/integration/mozilla-inbound/rev/0363b34d637c
Update reftest fuzz values as a result of WR cset f1569c04. r=jrmuizel
https://hg.mozilla.org/integration/mozilla-inbound/rev/14fcefb89e4f
Fix for change in WR cset da0b2138. r=jrmuizel
You need to log in before you can comment on or make changes to this bug.