Use the HTML inside the description. Look at the .TIWRECTANGLE1CSS . it has zindex < 0 and bacground color that is set to the coresponding table is not rendered.

RESOLVED DUPLICATE of bug 78087

Status

RESOLVED DUPLICATE of bug 78087
17 years ago
10 years ago

People

(Reporter: doychin, Assigned: attinasi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
<html>
	<head>
		<title>Guess the Number</title>
		<style TYPE="text/css"> .TIWRECTANGLE1CSS
{position:absolute;left:0;top:186;z-index:-1;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWBUTTON1CSS
{position:absolute;left:256;top:194;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWEDIT1CSS
{position:absolute;left:8;top:266;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWCHECKBOX1_INPUTCSS
{position:absolute;left:8;top:234;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWLABEL1CSS
{position:absolute;left:63;top:75;z-index:1;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWLABEL2CSS
{position:absolute;left:64;top:38;z-index:1;font-style:normal;font-size:10pt;text-decoration:none;}
	.LABLGUESSNOCSS
{position:absolute;left:63;top:120;z-index:1;font-style:normal;font-size:10pt;text-decoration:none;}
	.LINKQUITCSS
{position:absolute;left:279;top:159;z-index:1;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWRECTANGLE1CSS
{position:absolute;left:0;top:0;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWRECTANGLE2CSS
{position:absolute;left:0;top:299;z-index:3;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWRECTANGLE3CSS
{position:absolute;left:0;top:25;z-index:2;font-style:normal;font-size:10pt;text-decoration:none;}
	.IWRECTANGLE4CSS
{position:absolute;left:319;top:25;z-index:1;font-style:normal;font-size:10pt;text-decoration:none;}
	</style>
		<meta NAME="GENERATOR" Content="IWInternal Serial 2147462168">
	</head>
	<body>
		<form NAME="SubmitForm" ACTION="/Exec" METHOD="post">
			&nbsp;
			<button NAME="IWBUTTON1" VALUE="IWButton1" TYPE="button" STYLE="FONT-SIZE:
10pt;FONT-STYLE: normal;BACKGROUND-COLOR: #d4d0c8;TEXT-DECORATION: none"
ID="IWBUTTON1" CLASS="IWBUTTON1CSS">IWButton1</button>
			<input TYPE="text" NAME="IWEDIT1" SIZE="46" VALUE="IWEdit1" ID="IWEDIT1"
CLASS="IWEDIT1CSS">
			<span ID="IWCHECKBOX1_INPUT" NAME="IWCHECKBOX1" CLASS="IWCHECKBOX1_INPUTCSS">
      <input TYPE="checkbox" NAME="IWCHECKBOX1_INPUT" ID="IWCHECKBOX1"
ONCLICK="return IWCheckBox1_OnClick(this);">
      IWCheckBox1</span>
		</form>
		<table BGCOLOR="#0000ff" WIDTH="344" HEIGHT="113" BORDER="0" CELLPADDING="0"
CELLSPACING="0" ID="TIWRECTANGLE1" NAME="TIWRECTANGLE1" CLASS="TIWRECTANGLE1CSS">
			<tr>
				<td ALIGN="middle" VALIGN="center" HEIGHT="113">&nbsp;</td>
			</tr>
		</table>
		&nbsp;&nbsp;&nbsp;
		<table BGCOLOR="#c0dcc0" WIDTH="344" HEIGHT="25" BORDER="0" CELLPADDING="0"
CELLSPACING="0" ID="IWRECTANGLE1" NAME="IWRECTANGLE1" CLASS="IWRECTANGLE1CSS">
			<tr>
				<td ALIGN="middle" VALIGN="center" HEIGHT="25">&nbsp;</td>
			</tr>
		</table>
		<table BGCOLOR="#f0fbff" WIDTH="344" HEIGHT="25" BORDER="0" CELLPADDING="0"
CELLSPACING="0" ID="IWRECTANGLE2" NAME="IWRECTANGLE2" CLASS="IWRECTANGLE2CSS">
			<tr>
				<td ALIGN="middle" VALIGN="center" HEIGHT="25">&nbsp;</td>
			</tr>
		</table>
		<table BGCOLOR="#00ffff" WIDTH="25" HEIGHT="161" BORDER="0" CELLPADDING="0"
CELLSPACING="0" ID="IWRECTANGLE3" NAME="IWRECTANGLE3" CLASS="IWRECTANGLE3CSS">
			<tr>
				<td ALIGN="middle" VALIGN="center" HEIGHT="161">&nbsp;</td>
			</tr>
		</table>
		<table BGCOLOR="#808000" WIDTH="25" HEIGHT="161" BORDER="0" CELLPADDING="0"
CELLSPACING="0" ID="IWRECTANGLE4" NAME="IWRECTANGLE4" CLASS="IWRECTANGLE4CSS">
			<tr>
				<td ALIGN="middle" VALIGN="center" HEIGHT="161">&nbsp;</td>
			</tr>
		</table>
	</body>
</html>
(Reporter)

Comment 1

17 years ago
Created attachment 80622 [details]
Test HTML 

SOrry for the HTML in the description. I'm new to bugzile and did not know that
I can attach files to bug reports ;-(
Duplicate of "[regression] Doesn't display position:absolute and z-index:-1"

Per the CSS standard, this is correct rendering -- the negative-z-index element
is below the background of the page and hence not visible...

*** This bug has been marked as a duplicate of 78087 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Layout → GFX Compositor
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.