Remove support for submitting jobs via the REST API

RESOLVED DUPLICATE of bug 1349182

Status

P3
normal
RESOLVED DUPLICATE of bug 1349182
a year ago
9 months ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Reporter)

Description

a year ago
We would like to remove support for submitting jobs via the REST API and instead have people submit to us using Pulse (or else just using taskcluster instead).

See bug 1349182 for more details.
(Reporter)

Comment 1

a year ago
I guess one complication is that the more people who switch to using Pulse before bug 1395254 happens, the more third party submitters we'll have to migrate to a new version of the exchange too. Perhaps the treeherder Python client should support Pulse submission to help make this easier?
(Reporter)

Updated

a year ago
Depends on: 1395254
(Reporter)

Updated

a year ago
No longer depends on: 1395254
(Reporter)

Updated

9 months ago
Depends on: 1426586
(Reporter)

Updated

9 months ago
No longer depends on: 1426586
(Reporter)

Comment 2

9 months ago
Lets fold this into bug 1349182, since jobs submissions is the last piece remaining there.
No longer blocks: 1349182
Status: NEW → RESOLVED
Last Resolved: 9 months ago
No longer depends on: 1395326
Resolution: --- → DUPLICATE
Duplicate of bug: 1349182
You need to log in before you can comment on or make changes to this bug.