If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect rendering of SELECT OPTION, if resulted from XSLT

RESOLVED DUPLICATE of bug 1391118

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 1391118
20 days ago
13 days ago

People

(Reporter: Andy Schmidt, Unassigned)

Tracking

({regression})

55 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 fixed, firefox56 fix-optional, firefox57 affected)

Details

(Reporter)

Description

20 days ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

Steps to reproduce:

Simple test case:
1. Open http://staging.anamera.com/3rdPartyBugs/textxsl/FFdropdown.xml
2. Will fetch related XSLT
3. Renders SELECT / OPTIONs set 



Actual results:

In FF only, the output is a SELECT element without the ability to drop down through the 3 OPTIONs and choose one.


Expected results:

The SELECT should open and one should be able to choose from the OPTIONs.

Works correctly in IE, Edge, Chrome and Safari.
Only FireFox fails.

Updated

20 days ago
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → XSLT
Ever confirmed: true
Keywords: regression
Product: Firefox → Core

Comment 1

20 days ago
Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d66ec372454c676e487da5ba47167a79dcfea001&tochange=d02ab1fb2cbc43b425c2858d3b70f9ade88cfd65
Blocks: 1335483
Has Regression Range: --- → yes
Component: XSLT → Layout: Form Controls

Updated

20 days ago
status-firefox55: --- → affected
status-firefox56: --- → affected
status-firefox57: --- → affected
jaws, can you take a look since your patch may be the cause? Thanks.
status-firefox55: affected → fixed
status-firefox56: affected → fix-optional
Flags: needinfo?(jaws)
status-firefox-esr52: --- → unaffected
Status: NEW → RESOLVED
Last Resolved: 13 days ago
Flags: needinfo?(jaws)
Resolution: --- → DUPLICATE
Duplicate of bug: 1391118
You need to log in before you can comment on or make changes to this bug.