[/retention/thank-you pages] mobile download link points to SUMO article for Android

RESOLVED FIXED

Status

RESOLVED FIXED
a year ago
8 months ago

People

(Reporter: agibson, Unassigned, Mentored)

Tracking

({good-first-bug})

Production
good-first-bug

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
STR:

1.) Visit https://www.mozilla.org/en-US/etc/firefox/retention/thank-you-a/ or https://www.mozilla.org/en-US/etc/firefox/retention/thank-you-b/
2.) Underneath the heading "Get Firefox on your phone" click "Download Firefox"

Expected results:

The link should go to a consumer facing www.mozilla.org page where the user can download either Firefox for Android or Firefox for iOS e.g. https://www.mozilla.org/en-US/firefox/mobile-download/

Actual results:

The link goes to a SUMO article that talks about Firefox for Android only.
(Reporter)

Updated

a year ago
Keywords: good-first-bug
Mentor: schalk.neethling.bugs
Hi Alex and Schalk,

I can work on this.

Thanks!
Hi Alex,

Did the page change to: https://www.mozilla.org/en-US/firefox/new/ ?

Currently, I am able to view the two links in Steps to Reproduce online, but when I run locally at http://127.0.0.1:8000/ it shows the new page.

Is there a way to run the two thank-you pages?
Flags: needinfo?(agibson)
(Reporter)

Comment 3

8 months ago
It looks like this bug has already been fixed. Clicking the link as described in the steps to reproduce, it no longer goes to the SUMO article about Firefox for Android.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(agibson)
Resolution: --- → FIXED
(Reporter)

Comment 4

8 months ago
(In reply to Mai Truong from comment #2)
> Hi Alex,
> 
> Did the page change to: https://www.mozilla.org/en-US/firefox/new/ ?
> 
> Currently, I am able to view the two links in Steps to Reproduce online, but
> when I run locally at http://127.0.0.1:8000/ it shows the new page.
> 
> Is there a way to run the two thank-you pages?

I'm not sure what steps you're trying here, but neither /firefox/new/ nor the home page are the page in question for this bug. The pages we're /etc/firefox/retention/thank-you-a/ and /etc/firefox/retention/thank-you-b/.
I was trying to run the page locally according the instructions at http://bedrock.readthedocs.io/en/latest/install.html. I found the github repo and README.md from the "Source code for this page" link. 

Originally I thought you wanted to change the link of "Download Firefox" to https://www.mozilla.org/en-US/firefox/mobile-download/ instead of the current one (https://www.mozilla.org/en-US/firefox/mobile-download/desktop/). But since it also has the direct link  to Play Store / App Store, it's all good.

Thanks!
You need to log in before you can comment on or make changes to this bug.