Firefox is running slow with NVDA and Youtube

REOPENED
Unassigned

Status

()

P2
normal
REOPENED
a year ago
7 months ago

People

(Reporter: roxana.leitan, Unassigned)

Tracking

57 Branch
All
Windows
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Whiteboard: aes+)

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170830220349

[Affected versions]:
Nightly 57.0a1

[Affected platforms]:
Windows 10 x64, Windows 10 x86, Windows 7 x86

[Steps to reproduce]:
1.Enable NVDA
2.Enable KAV 10.3.0
3.Launch Nightly 57.0a1 with a new profile
4.Open websites with media ( e.g. youtube.com)

[Expected result]:
The websites are displayed without issues

[Actual result]:
Firefox is running very slow
(Reporter)

Updated

a year ago
OS: All → Windows

Updated

11 months ago
Component: DOM: Content Processes → Disability Access APIs
Whiteboard: aes+

Updated

11 months ago
Flags: needinfo?(dbolter)
Roxana, is the problem different if KAV is not enabled?
Flags: needinfo?(dbolter) → needinfo?(roxana.leitan)
(Reporter)

Comment 2

11 months ago
Tested on latest Nightly 58.0a1 (Build ID:20170928220658)on Windows 10 with Kaspersky antivirus on and off and is no difference.

But FF is not that slow like it was when I filed the bug. I think because the fix for bug 1384336 was backed out (comment 32 from bug 1384336).

Please note that on Windows 7, FF was slower than on Win 10 (on Nightly 57.0a1), but I cannot test on Win 7 with KAV off(due to security policy).
Flags: needinfo?(roxana.leitan)

Updated

11 months ago
Flags: needinfo?(jmathies)

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME

Updated

9 months ago
Blocks: 1423628

Comment 3

9 months ago
Roxana - if you set the pref dom.ipc.useNativeEventProcessing.content to false (and restart), can you reproduce this again?
Flags: needinfo?(roxana.leitan)
(Reporter)

Comment 4

8 months ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171211220110

I reproduced the issue on Windows 10 x64 using Nightly 59.0a1 with pref dom.ipc.useNativeEventProcessing.content set to False, NVDA and KAV enabled.
Flags: needinfo?(roxana.leitan)

Comment 5

8 months ago
(In reply to roxana.leitan@softvision.ro from comment #4)
> Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101
> Firefox/59.0
> Build ID: 20171211220110
> 
> I reproduced the issue on Windows 10 x64 using Nightly 59.0a1 with pref
> dom.ipc.useNativeEventProcessing.content set to False, NVDA and KAV enabled.

Does this happen without KAV?
Things seem pretty much the same for me with it enabled or disabled on the latest Nightly, but I don't have Kaspersky.
Flags: needinfo?(roxana.leitan)
(Reporter)

Comment 6

8 months ago
Mozilla/5.0 (Windows NT 10.0; rv:59.0) Gecko/20100101 Firefox/59.0 
Build ID:20171214220032

I reproduced the issue on Windows 10 x86 using Nightly 59.0a1 with Kaspersky disabled and NVDA enabled, with and without pref dom.ipc.useNativeEventProcessing.content.
I tested on youtube page; the browser is running slow when scrolling down the page, sometimes the sound is blocked for few seconds.  

Tested again on Windows 10 x64 with the latest Nightly build and the issue is a bit intermittent(there are time periods in which the video seems ok and others in which it lags horribly - I didn't identify any pattern related to this).
Flags: needinfo?(roxana.leitan)

Comment 7

8 months ago
(In reply to roxana.leitan@softvision.ro from comment #6)
...
> I reproduced the issue on Windows 10 x86 using Nightly 59.0a1 with Kaspersky
> disabled and NVDA enabled, with and without pref
> dom.ipc.useNativeEventProcessing.content.

Sorry, just to be clear, are you saying that you are getting the problem and that the dom.ipc.useNativeEventProcessing.content makes no difference or are you saying that you only get it with dom.ipc.useNativeEventProcessing.content set to false?
Flags: needinfo?(roxana.leitan)
(Reporter)

Comment 8

8 months ago
Hi Bob,
Yes, I reproduced the issue(described in comment 6) and the dom.ipc.useNativeEventProcessing.content makes no difference.
Flags: needinfo?(roxana.leitan)

Comment 9

8 months ago
Thanks Roxana.

Jamie - I'm guessing that there might already be a different bug this should block or that is a duplicate.
No longer blocks: 1423628
Status: RESOLVED → REOPENED
Flags: needinfo?(jteh)
Resolution: WORKSFORME → ---

Comment 10

8 months ago
I'm not aware of any bug specifically covering this. Note that a lot of the performance issues with Firefox and NVDA are fixed in 58/59 (as compared with 57). If I understand correctly, this bug seems to be somewhat specific to Youtube (and perhaps other sites with media). I'm narrowing the scope to just cover Youtube for now; we can deal with other specific use cases in follow ups if necessary.

(In reply to roxana.leitan@softvision.ro from comment #6)
> I tested on youtube page; the browser is running slow when scrolling down
> the page, sometimes the sound is blocked for few seconds.  

1. When you say "scrolling down the page", do you mean with the mouse or with the arrow keys? (The arrow keys are overridden by NVDA to navigate in "browse mode", which is why this is relevant.)
2. If you scroll while the video is paused, do you seem the same slowness?
3. Do you see slowness/video choppiness when you *aren't* scrolling?
Flags: needinfo?(jteh) → needinfo?(roxana.leitan)
Summary: Firefox is running slow with NVDA → Firefox is running slow with NVDA and Youtube
(Reporter)

Comment 11

8 months ago
Created attachment 8940150 [details]
2018-01-05_11h39_31.mp4
Flags: needinfo?(roxana.leitan)
(Reporter)

Comment 12

8 months ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0  
Build ID: 20180104220114

> 1. When you say "scrolling down the page", do you mean with the mouse or
> with the arrow keys? (The arrow keys are overridden by NVDA to navigate in
> "browse mode", which is why this is relevant.)

I scroll the page using the mouse wheel/dragging the scrollbar.

> 2. If you scroll while the video is paused, do you seem the same slowness?
Yes. the browser is running slow even if the video is paused. Please see the attached screencast.

> 3. Do you see slowness/video choppiness when you *aren't* scrolling?

Without scrolling, I don't see slowness/video choppiness. But if I click "play next video" button for more than 3 videos, I see video choppiness and the video resolution is low for a while. (please see "youtube+NVDA video resolution" attachment)
(Reporter)

Comment 13

8 months ago
Created attachment 8940152 [details]
youtube+NVDA video resolution.png
setting as P2, Jamie, please adjust is if necessary
Priority: -- → P2
You need to log in before you can comment on or make changes to this bug.