https://messenger.yahoo.com/ page is not rendered correctly at scroll up/down with advanced layers

RESOLVED DUPLICATE of bug 1390942

Status

()

Core
Graphics: Layers
P3
normal
RESOLVED DUPLICATE of bug 1390942
10 months ago
7 months ago

People

(Reporter: cmarius, Assigned: dvander)

Tracking

({regression})

Trunk
x86_64
Windows
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 disabled, firefox57 fixed)

Details

(Whiteboard: gfx-noted, URL)

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Firefox: 57.0a1, Build ID: 20170830220349

Notes:
- Make sure you're not logged in on https://messenger.yahoo.com/.
- The issue is not reproducible with "layers.mlgpu.enable-on-windows7" set to false.

Affected versions:
- Nightly 57.0a1 x64 and x86

Affected Platforms:
- All Windows

Prerequisites:
- Have latest Nightly istalled.

Steps to reproduce:
1. Open Nightly.
2. Go to https://messenger.yahoo.com/ .
3. Scroll down.
4. Observe the page behaviour.

Expected result:
- Page is redered correctly.

Actual result:
- Page breaks at scroll down.

Regression window:
Last good revision: 4be7a444608778a6ff9f53fcdcee2d1f89e5ae65
First bad revision: 5b29bf0b577c67d9486aa95a09f36a39c0a67754
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4be7a444608778a6ff9f53fcdcee2d1f89e5ae65&tochange=5b29bf0b577c67d9486aa95a09f36a39c0a67754

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1379731
Flags: needinfo?(dvander)

Updated

10 months ago
Priority: -- → P3
Whiteboard: gfx-noted
Advanced layers are off by default until 58.
Assignee: nobody → dvander
status-firefox56: affected → unaffected
status-firefox57: affected → unaffected
Flags: needinfo?(dvander)
Summary: https://messenger.yahoo.com/ page is not rendered correctly at scroll up/down → https://messenger.yahoo.com/ page is not rendered correctly at scroll up/down with advanced layers
Off by one error - advanced layers not in 56, but in 57.
status-firefox57: unaffected → affected
status-firefox56: unaffected → disabled
status-firefox-esr52: --- → unaffected
(In reply to Marius Coman [:cmarius] from comment #0)

Marius, can you attach a copy of about:support from where you were able to reproduce this? As well as a screenshot or video of how it is rendering incorrectly?

Also, you mentioned this affects all versions of Windows, but that it's affected by a Windows 7-specific preference. Are you able to reproduce on Windows 8/10?
Flags: needinfo?(marius.coman)
(Reporter)

Comment 4

9 months ago
Created attachment 8907552 [details]
about_support.txt

In the attachment you will find a copy of about:support and here is a screen recording of the initial behavior from 2017-08-30 build: https://goo.gl/fgiyNA
The issue was reproducible on Windows 7, Windows 8 and Windows 10.

On the latest Nightly Build (57.0a1) the behaviour has changed because of: 

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6e0eb137038981bb7d8781d2842cdf982361c82c&tochange=86a0af16631d9369dbe3f0e87e88400f6bd05f63

It seems that bug 1390942 changed the initial behaviour and now the page has a flicker at scroll up / down when the browser is maximized ( or >1080p).

Here is a screen recording of the new behavior from 2017-09-12 build: https://goo.gl/qUp2Fk
Flags: needinfo?(marius.coman)
(In reply to Marius Coman [:cmarius] from comment #4)
> Created attachment 8907552 [details]
> about_support.txt
> 
> In the attachment you will find a copy of about:support and here is a screen
> recording of the initial behavior from 2017-08-30 build:
> https://goo.gl/fgiyNA
> The issue was reproducible on Windows 7, Windows 8 and Windows 10.
> 
> On the latest Nightly Build (57.0a1) the behaviour has changed because of: 
> 
> Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=6e0eb137038981bb7d8781d2842cdf982361c82c&tochange=86a0
> af16631d9369dbe3f0e87e88400f6bd05f63
> 
> It seems that bug 1390942 changed the initial behaviour and now the page has
> a flicker at scroll up / down when the browser is maximized ( or >1080p).
> 
> Here is a screen recording of the new behavior from 2017-09-12 build:
> https://goo.gl/qUp2Fk

It sounds like bug 1390942 fixed the original reported issue. Marius, does the new issue reproduce for you if you set layers.mlgpu.enabled = false in about:config?
Flags: needinfo?(marius.coman)
(Reporter)

Comment 6

9 months ago
Yes, the new issue is still reproducible if I set layers.mlgpu.enabled = false in about:config.
Flags: needinfo?(marius.coman)
Okay, it sounds like the original issue has been fixed then, and the new issue is separate. I'm going to dupe this against bug 1390942 - could you file a new bug for the other issue? A regression range would help too - you'll probably have to set layers.mlgpu.enabled = false & layers.mlgpu.dev-enabled = false to get an accurate reading.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1390942
status-firefox57: affected → fixed
You need to log in before you can comment on or make changes to this bug.