Closed Bug 1395573 Opened 5 years ago Closed 3 years ago

CustomTab: "Edit site settings" not displayed

Categories

(Firefox for Android Graveyard :: Custom Tabs, defect, P5)

57 Branch
ARM
Android
defect

Tracking

(fennec+, firefox57 wontfix, firefox58 affected, firefox59 affected, firefox60 affected, firefox61 affected, firefox62 affected, firefox63 affected, firefox64 affected, firefox65 affected, firefox66 affected, firefox67 affected, firefox68 affected)

RESOLVED WONTFIX
Tracking Status
fennec + ---
firefox57 --- wontfix
firefox58 --- affected
firefox59 --- affected
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected
firefox64 --- affected
firefox65 --- affected
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected

People

(Reporter: sflorean, Unassigned)

References

Details

Environment: 
Device: Huawei Honor (Android 5.1.1), Asus ZenPad 8 (Android 6.0.1);
Build: Nightly 57.0a1 (2017-08-30);
Prerequisite: Custom tabs are enabled in settings.

Steps to reproduce:
1. Go to https://sjeng.org/mozilla/geo.html; 
2. Tap on "Share" from doorhanger.
3. Tap on green lock.

Expected result:
A message is displayed with information about site and with option "Edit Site settings", option that clears the settings made for that site.

Actual result:
No "Edit Site settings" option is displayed to clear the settings made.
We probably can't do this in time for 57. GeckoView has no site permissions API and we'd also need someone to rewrite the frontend bits.
tracking-fennec: ? → +
Priority: -- → P2
Snorp, is this feasible now? If so, please NI me.

[triage] Setting to P3 rank 0 because if GeckoView doesn't support this, it's not actionable.
Flags: needinfo?(snorp)
Priority: P2 → P3
GV still does not support anything around site settings currently.
Flags: needinfo?(snorp)
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P3 → P5
Hi,

I was able to reproduce the issue.

Tested with:
Browser / Version: Firefox Mobile Nightly 63.0a1 (2018-08-09)
Operating System: Sony Xperia Z5 Premium (Android 6.0.1)

Thank you!
Component: General → Custom Tabs

"Edit site settings" not displayed, regardless of Custom tabs being enabled or disabled.

This is infuriating as a garbage news media site I visited somehow got the privilege of sending push notifications through the Firefox app, and I have no way that I know of to revoke that privilege.

picture: https://twitter.com/sv1floki/status/1155963731840344064

Device: Samsung Galaxy S7 edge (Android 8.0.0)
Build: [not sure, it's the current up to date "Firefox Browser fast & private" from Play Store (2019-07-30)] about:firefox says Firefox 68.0
Prerequisite: none, "Edit site settings" does never show

Is there a way this could be added as a feature for ESR?

Flags: needinfo?(sarentz)

I am closing this since this is a major new feature request for Fennec. Instead, I have filed the following Firefox Preview (Fenix) issue:

https://github.com/mozilla-mobile/fenix/issues/6034

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(sarentz)
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.