Bookmark Toolbar changes size when switching between customize mode and another tab

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: maruf.rahman.95, Assigned: dao)

Tracking

(Blocks: 1 bug)

57 Branch
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 verified)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Build ID  : 20170831100258
user Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 
            Firefox/57.0
OS        : Windows 7 , 64 Bit

Steps to Reproduce : 

1. Open Firefox Nightly 
2. Open Customization and enable bookmark toolbar
3. Make sure you have another tab opened besides customization

Actual Result  : If I switch from customization tab to the other tab, the toolbar 
                 goes up (maybe by some pixel). And if I switch from that tab to 
                 customization ,the toolbar comes down.

Expected Result: The toolbar should not show this kind of behavior

Updated

2 years ago
See Also: → bug 1389966, bug 1389167
Summary: Bookmark Toolbar goes up when switching to another tab from customization → Bookmark Toolbar changes size when switching between customize mode and another tab
Whiteboard: [photon-visual][triage][photon-structure][triage]
(Assignee)

Updated

2 years ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED

Comment 2

2 years ago
mozreview-review
Comment on attachment 8904509 [details]
Bug 1395596 - Avoid changing the bookmarks toolbar's height when entering customize mode and the toolar is non-empty.

https://reviewboard.mozilla.org/r/176362/#review181250

::: browser/themes/shared/browser.inc.css
(Diff revision 1)
> -  /* There's no border in customize mode, so we don't need extra padding. */
> -  padding-bottom: 0;

Sorry, but why are we no longer removing the 1px padding set above this? Does the additional height match better that way, or something? :-)
Attachment #8904509 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 3

2 years ago
(In reply to :Gijs (queue backed up, slow) from comment #2)
> Comment on attachment 8904509 [details]
> Bug 1395596 - Avoid changing the bookmarks toolbar's height when entering
> customize mode and the toolar is non-empty.
> 
> https://reviewboard.mozilla.org/r/176362/#review181250
> 
> ::: browser/themes/shared/browser.inc.css
> (Diff revision 1)
> > -  /* There's no border in customize mode, so we don't need extra padding. */
> > -  padding-bottom: 0;
> 
> Sorry, but why are we no longer removing the 1px padding set above this?
> Does the additional height match better that way, or something? :-)

It would matter if we add support for custom / web extension toolbars (bug 1215064). Removing the padding doesn't seem useful anyway, or is there some specific problem this solves?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 4

2 years ago
(In reply to Dão Gottwald [::dao] from comment #3)
> (In reply to :Gijs (queue backed up, slow) from comment #2)
> > Comment on attachment 8904509 [details]
> > Bug 1395596 - Avoid changing the bookmarks toolbar's height when entering
> > customize mode and the toolar is non-empty.
> > 
> > https://reviewboard.mozilla.org/r/176362/#review181250
> > 
> > ::: browser/themes/shared/browser.inc.css
> > (Diff revision 1)
> > > -  /* There's no border in customize mode, so we don't need extra padding. */
> > > -  padding-bottom: 0;
> > 
> > Sorry, but why are we no longer removing the 1px padding set above this?
> > Does the additional height match better that way, or something? :-)
> 
> It would matter if we add support for custom / web extension toolbars (bug
> 1215064). Removing the padding doesn't seem useful anyway, or is there some
> specific problem this solves?

I think I originally intended to match the height of the toolbar with items vs. without items. But then I reduced the height after the review feedback, and there's bug 1389966 on file for that (sort of), so I don't really mind either way.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 5

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c32a5bb6a6df
Avoid changing the bookmarks toolbar's height when entering customize mode and the toolar is non-empty. r=Gijs
(Assignee)

Updated

2 years ago
Blocks: 1325171
Priority: -- → P1
Whiteboard: [photon-visual][triage][photon-structure][triage] → [reserve-photon-visual]
Iteration: --- → 57.3 - Sep 19
Flags: qe-verify?
(Assignee)

Updated

2 years ago
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
https://hg.mozilla.org/mozilla-central/rev/c32a5bb6a6df
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
(Reporter)

Comment 7

2 years ago
I have reproduced this bug with Nightly 57.0a1 (2017-08-31) on Ubuntu 16.04 LTS!

This bug's fix is verified with latest Nightly!

Build ID  : 20170910100150
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170906]

Comment 8

2 years ago
I have reproduced this bug with Nightly 57.0a1 (2017-08-31) on Windows 8.1, 64-Bit ! 

This bug's fix is Verified with latest Nightly !

Build   ID    20170909100226
User Agent    Mozilla/5.0 (Windows NT 6.3; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday-20170906]
QA Whiteboard: [bugday-20170906]
(Reporter)

Comment 9

2 years ago
As per comment 7 and comment 8 , I am marking this bug as Verified Fixed!
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.