Closed Bug 139569 Opened 21 years ago Closed 21 years ago

colgroups with align and span attributes are not rendering correctly

Categories

(Core :: Layout: Tables, defect)

x86
Windows NT
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 915

People

(Reporter: paul.nendick, Assigned: karnaze)

References

()

Details

Attachments

(4 files)

This has also been tested with the same version of Mozilla on Linux with
identical resultant behavior.

Mozilla doesn't appear to honor the attributes 'span' and 'align' within
'colgroups' when rendering tables.  The attached examples were created by
running the code sample found at
http://www.w3.org/TR/html401/struct/tables.html#h-11.5 through "HTML Tidy"
version "1st March 2002" found at http://tidy.sourceforge.net and then through
Mozilla 0.99.

The attached images compare the results given by the w3 document
(colgroups_w3c.org), IE 5.0 (colgroups_ie5.org), and Mozilla 0.99
(colgroups_moz99.png).  The html file used in the latter two tests is also
attached (colgroups.html).
Duplicate of "rules=groups doesn't respect colgroups"

*** This bug has been marked as a duplicate of 127798 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Reopening to dupe it to correct bug 915

 Bug 915 describes that align and valign attributes of col and colgroups are not 
working.

*** This bug has been marked as a duplicate of 915 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.