Closed Bug 1395761 Opened 2 years ago Closed 2 years ago

Highlights icons not centered

Categories

(Firefox for Android :: Awesomescreen, enhancement, P1)

All
Android
enhancement

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
1.30
Tracking Status
fennec + ---
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: mcomella, Assigned: mcomella)

References

Details

(Whiteboard: [mobileAS])

Attachments

(5 files)

Attached image Screenshot
Highlights icons are intentionally wider than they are tall but it looks like the icons we provide are not centered - which is weird because I could have sworn they were fitCenter. See the attached screenshot.
Priority: -- → P2
tracking-fennec: ? → +
Rank: 2
I discovered the margin seems to push the view to one side: see the attached screenshot.

I removed the margins and the view is correctly centered - yay!

So we need to figure out why the other views aren't resizing to take into account the added margin.
Iteration: --- → 1.30
Rank: 2
Priority: P2 → P1
Assignee: nobody → michael.l.comella
Duplicate of this bug: 1397891
Comment on attachment 8906677 [details]
Bug 1395761: Remove layout_gravity=center in webpage_item_row.

https://reviewboard.mozilla.org/r/178396/#review183378

Simple change, fixes the layout, lgtm.
Attachment #8906677 - Flags: review?(liuche) → review+
Pushed by michael.l.comella@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ab339292ac6b
Remove layout_gravity=center in webpage_item_row. r=liuche
https://hg.mozilla.org/mozilla-central/rev/ab339292ac6b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Icons are now centered on both phones and tablets. Marking as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.