Closed Bug 1395987 Opened 7 years ago Closed 6 years ago

Have WebRender compute the screen-space invalid rect and scissor out the rest when possible.

Categories

(Core :: Graphics: WebRender, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected

People

(Reporter: nical, Unassigned)

References

Details

(Whiteboard: gfx-noted)

We currently save some memory bandwidth by avoiding to composite areas of the window that have not been invalidated and pass that invalidation information to the window manager.

WebRender does not support that. Gecko currently does it with intel and amd gpus (not nvidia because of some driver issue I assume).

WebRender issue about this: https://github.com/servo/webrender/issues/962

We may not need this to ship WebRender but not doing this optimization would at least come at the cost of battery life regressions for things like watching videos (that are not full screen), or when a there is no scrolling but something small changes in the page like a spinner.

We're already doing this now right?

Flags: needinfo?(gwatson)

We do calculate the dirty rect, and scissor out everything else. The (possibly) missing part from this bug is that we still always present the whole screen using the cached tiles, instead of doing some kind of partial present with the information we now have available.

Flags: needinfo?(gwatson)

Ok. Let's close this bug then.

Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.