Background of Bloomberg article-headline is askew in Firefox

VERIFIED DUPLICATE of bug 1391430

Status

()

Core
ImageLib
P2
normal
VERIFIED DUPLICATE of bug 1391430
10 months ago
9 months ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

57 Branch
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox56 unaffected, firefox57 fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
STR:
 1. Visit this URL in Firefox on Android:
https://www.bloomberg.com/graphics/2017-kushners-china-deal-flop-was-part-of-much-bigger-hunt-for-cash/

 2. Look at the fast-slideshow of images behind the article headline (which look like building floor plans)

EXPECTED RESULTS:
The images should look nice and square -- top-down floor plan views.

ACTUAL RESULTS:
The images are askew - the lines that should be vertical are squashed ~45 degrees to the right.


I suspect there's some transformed layer that's getting mis-transformed here, or something.

AFFECTED: Firefox Nightly (57.0a1 2017-08-31) on Android

UNAFFECTED:
 Firefox Beta (56.0b7) on Android
 Firefox Nightly on Desktop

So this seems to be a regression in current Nightly, and it seems to be Android-only (not Desktop).

I al
Happens if you load the animated GIF standalone too.

Andrew, you've been poking at some of this stuff recently, do you know what might be happening? It works fine in FF beta, so it's a relatively recent regression.
status-firefox56: --- → unaffected
status-firefox57: --- → affected
Flags: needinfo?(aosmond)
Keywords: regressionwindow-wanted
OS: Unspecified → Android
Priority: -- → P2
Hardware: Unspecified → All
Version: unspecified → 57 Branch
(Reporter)

Comment 2

10 months ago
Created attachment 8903705 [details]
screenshot of bug
(Reporter)

Comment 3

10 months ago
Created attachment 8903706 [details]
testcase 1 (animated GIF from the site that triggers this)
Yes this was my regression. I fixed it, but it did not land on central until yesterday afternoon. Either the current or next nightly release for Android should pick it up. Please reopen if the issue is still there after updating (and paste the build ID from about:support so I can confirm the presence or lack thereof of the fix).
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1391430
(Reporter)

Comment 5

10 months ago
Yup, just noticed & installed today's update via Play Store & confirmed that the updated version is unaffected.

--> Verified dupe. Thanks!
Status: RESOLVED → VERIFIED
Keywords: regressionwindow-wanted
(Reporter)

Updated

10 months ago
Component: Graphics, Panning and Zooming → ImageLib
Product: Firefox for Android → Core
Per bug 1391430.
status-firefox57: affected → fixed
You need to log in before you can comment on or make changes to this bug.