Closed Bug 1396268 Opened 3 years ago Closed 3 years ago

Crash in java.lang.AssertionError: Expected condition to be true at org.mozilla.gecko.media.GeckoHlsPlayer.assertTrue(GeckoHlsPlayer.java)

Categories

(Firefox for Android :: Audio/Video, defect, P1)

All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: JanH, Assigned: kikuo)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-081acf46-fedc-43b7-982e-6e6a10170901.
=============================================================

From the crash stack, we're hitting the assertion here:
https://hg.mozilla.org/mozilla-central/annotate/9679bdd8b0a3/mobile/android/geckoview/src/main/java/org/mozilla/gecko/media/GeckoHlsPlayer.java#l712
Assignee: nobody → kikuo
Priority: -- → P1
Look into the code, the default value returned by getFirstStamplePTS() is Long.MIN_VALUE, so the only possibility for this crash is that this line of code [1] is not hit, which means that renderers are set to null before seek() is invoked.

Considering the rate of this crash and since GeckoHLSPlayer.release() may be called by GeckoHlsResourceWrapper or GeckoHlsDemuxerWrapper, I'll add condition check for that to fix this.

'''
startTime = Math.min(startTime, r.getFirstSamplePTS());
'''

[1] http://searchfox.org/mozilla-central/rev/67f38de2443e6b613d874fcf4d2cd1f2fc3d5e97/mobile/android/geckoview/src/main/java/org/mozilla/gecko/media/GeckoHlsPlayer.java#705
Comment on attachment 8905420 [details]
Bug 1396268 - Seek operation should not be performed after GeckoHlsPlayer.release is called!

https://reviewboard.mozilla.org/r/177236/#review182234
Attachment #8905420 - Flags: review?(jacheng) → review+
This might be a timing issue caused by Bug 1395015 which might change the release timing from MediaResource destructor to HLSDecoder::Shutdown.

But we still need this patch to check this status earlier.
Pushed by kikuo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0cd3d257e736
Seek operation should not be performed after GeckoHlsPlayer.release is called! r=JamesCheng
https://hg.mozilla.org/mozilla-central/rev/0cd3d257e736
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.