Startup crash in nsTArray_Impl<T>::AppendElement<T> | mozilla::Preferences::AddBoolVarCache

RESOLVED DUPLICATE of bug 1276488

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1276488
2 years ago
2 years ago

People

(Reporter: philipp, Unassigned)

Tracking

(4 keywords)

56 Branch
All
Windows
Points:
---

Firefox Tracking Flags

(firefox56+ fix-optional, firefox57 fix-optional)

Details

(crash signature)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]:
this is a startup crash increasing in volume during the 56.0b cycle

This bug was filed from the Socorro interface and is 
report bp-5fcc636b-1074-4552-81f7-936970170902.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsTArray_Impl<nsAutoPtr<mozilla::CacheData>, nsTArrayInfallibleAllocator>::AppendElement<mozilla::CacheData*&, nsTArrayInfallibleAllocator>(mozilla::CacheData*&) 	obj-firefox/dist/include/nsTArray.h:2198
1 	xul.dll 	mozilla::Preferences::AddBoolVarCache(bool*, char const*, bool) 	modules/libpref/Preferences.cpp:2021
2 	xul.dll 	mozilla::net::nsIOService::Init() 	netwerk/base/nsIOService.cpp:252
3 	xul.dll 	mozilla::net::nsIOService::GetInstance() 	netwerk/base/nsIOService.cpp:347
4 	xul.dll 	nsIOServiceConstructor 	netwerk/build/nsNetModule.cpp:62
5 	xul.dll 	nsComponentManagerImpl::CreateInstanceByContractID(char const*, nsISupports*, nsID const&, void**) 	xpcom/components/nsComponentManager.cpp:1101
6 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID(char const*, nsID const&, void**) 	xpcom/components/nsComponentManager.cpp:1457
7 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid(nsGetServiceByContractID, nsID const&) 	xpcom/base/nsCOMPtr.cpp:95
8 	xul.dll 	nsCOMPtr<nsIIOService>::nsCOMPtr<nsIIOService>(nsGetServiceByContractID) 	xpcom/base/nsCOMPtr.h:555
9 	xul.dll 	do_GetIOService(nsresult*) 	netwerk/base/nsNetUtil.cpp:88
10 	xul.dll 	NS_NewURI(nsIURI**, nsACString const&, char const*, nsIURI*, nsIIOService*) 	netwerk/base/nsNetUtil.cpp:1534
11 	xul.dll 	nsChromeRegistry::ManifestProcessingContext::GetManifestURI() 	chrome/nsChromeRegistryChrome.cpp:617
12 	xul.dll 	nsChromeRegistry::ManifestProcessingContext::ResolveURI(char const*) 	chrome/nsChromeRegistryChrome.cpp:625
13 	xul.dll 	nsChromeRegistryChrome::ManifestLocale(nsChromeRegistry::ManifestProcessingContext&, int, char* const*, int) 	chrome/nsChromeRegistryChrome.cpp:706
14 	xul.dll 	ParseManifest(NSLocationType, mozilla::FileLocation&, char*, bool, bool) 	xpcom/components/ManifestParser.cpp:760
15 	xul.dll 	DoRegisterManifest 	xpcom/components/nsComponentManager.cpp:567
16 	xul.dll 	nsComponentManagerImpl::ManifestManifest(nsComponentManagerImpl::ManifestProcessingContext&, int, char* const*) 	xpcom/components/nsComponentManager.cpp:589
17 	xul.dll 	ParseManifest(NSLocationType, mozilla::FileLocation&, char*, bool, bool) 	xpcom/components/ManifestParser.cpp:769
18 	xul.dll 	DoRegisterManifest 	xpcom/components/nsComponentManager.cpp:567
19 	xul.dll 	nsComponentManagerImpl::RereadChromeManifests(bool) 	xpcom/components/nsComponentManager.cpp:741
20 	xul.dll 	nsComponentManagerImpl::Init() 	xpcom/components/nsComponentManager.cpp:364
21 	xul.dll 	NS_InitXPCOM2 	xpcom/build/XPCOMInit.cpp:684
22 	xul.dll 	ScopedXPCOMStartup::Initialize() 	toolkit/xre/nsAppRunner.cpp:1524
23 	xul.dll 	XREMain::XRE_main(int, char** const, mozilla::BootstrapConfig const&) 	toolkit/xre/nsAppRunner.cpp:4768
24 	xul.dll 	XRE_main(int, char** const, mozilla::BootstrapConfig const&) 	toolkit/xre/nsAppRunner.cpp:4867
25 	firefox.exe 	NS_internal_main(int, char**, char**) 	browser/app/nsBrowserApp.cpp:309
26 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:115
27 	firefox.exe 	__scrt_common_main_seh 	f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:253
Ø 28 	kernel32.dll 	kernel32.dll@0x11ff3 	
Ø 29 	ntdll.dll 	ntdll.dll@0x61f70 	
Ø 30 	kernelbase.dll 	kernelbase.dll@0xe999f

the crash signature has been around for a while but it's visibly increasing in volume during the 56 beta cycle. a couple dozen affected installations are crashing hundreds of times during startup of the browser.
Component: Untriaged → Preferences: Backend
Keywords: crashreportid
Track 56+ as this startup crash is increasing.
Nicholas, can you help find someone to investigate since this is spiking dramatically in beta?
Flags: needinfo?(n.nethercote)
I will dup this to bug 1276488 because there is already some analysis there.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(n.nethercote)
Resolution: --- → DUPLICATE
Duplicate of bug: 1276488
Marking fix-optional for 56/57; while this shows as a top crash in beta it's a large number of crashes for only 20 installations. We can follow this in the duplicate bug.
You need to log in before you can comment on or make changes to this bug.