The speech bubble box-shadow in RTL is incorrect

VERIFIED FIXED in Firefox 57

Status

()

P3
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: gasolin, Assigned: gasolin)

Tracking

57 Branch
Firefox 57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified, firefox58 verified)

Details

(Whiteboard: [photon-onboarding][photon-onboarding-newui])

Attachments

(1 attachment)

(Assignee)

Description

a year ago
The shadow is still at left instead of at right side in RTL mode.

step to reproduce:

* when onboarding speech bubble is shown
* open devtool inspector and change `body dir="ltr"` to `body dir="rtl"`

expect:

The shadow of speech bubble is at right side in RTL mode.
(Assignee)

Updated

a year ago
Assignee: nobody → gasolin
Flags: qe-verify+
Priority: -- → P3
Whiteboard: [photon-onboarding][photon-onboarding-newui]
(Assignee)

Comment 1

a year ago
should do after bug 1392472 land since it includes `onboarding-overlay-button::after` style change
Depends on: 1392472

Updated

a year ago
Status: NEW → ASSIGNED
QA Contact: jwilliams
Comment hidden (mozreview-request)

Comment 3

a year ago
mozreview-review
Comment on attachment 8904859 [details]
Bug 1396477 - fix the onboarding speech bubble box-shadow in RTL;

https://reviewboard.mozilla.org/r/176634/#review181698
Attachment #8904859 - Flags: review?(rexboy) → review+

Comment 4

a year ago
Pushed by flin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7d9dde6b07c4
fix the onboarding speech bubble box-shadow in RTL;r=rexboy

Comment 5

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7d9dde6b07c4
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have verified that this issue is no longer reproducible on Win 10 x64, Win 7 x86, Mac 10.13, & Ubuntu 16.04 x32 with Firefox 58.
status-firefox58: --- → verified
I can confirm the intended behavior is respected on beta. I verified using Fx 57.0b7 on Windows 10 x64, Ubuntu 14.04 LTS and macOS X 10.12.6.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.