Closed Bug 1396839 Opened 4 years ago Closed 3 years ago

"Nightly Start Page" tooltip is displayed for "Home" button when Activity Stream overrides about:home

Categories

(Firefox :: New Tab Page, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 62
Iteration:
62.2 - Jun 4
Tracking Status
firefox57 --- wontfix
firefox58 --- wontfix
firefox62 --- verified

People

(Reporter: cmuresan, Assigned: Mardak)

References

Details

Attachments

(3 files, 1 obsolete file)

[Affected versions]:
- Firefox 57.0a1 Build ID 20170904220027

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- browser.newtabpage.activity-stream.enabled is set to true in about:config on a clean new profile.
- browser.newtabpage.activity-stream.aboutHome.enabled is set to true in about:config in the same profile. 

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites.
2. Hover the Home button and observe the tooltip.
 
[Expected results]:
- A tooltip that reflects the redirection to Activity Stream is displayed.

[Actual results]:
- "Nightly Start Page" tooltip is displayed.

[Notes]:
- The title of the about:home page is "Firefox/Nightly Start Page". But if AS overrides the about:home page, the page title remains "New Tab".
- Attached a screen recording of the issue.
Design says generally 'In the various places that say "Firefox Start Page" it should be "Firefox Home Page". This would include the about:preferences, etc.
This string comes from aboutHome.dtd, which if it were somewhere else, e.g., browser.properties, there could be a clean removal of the to-be-unused file in bug 1409054.
Blocks: 1409054
Attached image v1 screenshot (obsolete) —
Assignee: nobody → edilee
Status: NEW → ASSIGNED
(In reply to Ed Lee :Mardak from comment #5)
> flod, should I just copy over most of the existing localization note:
> https://searchfox.org/mozilla-central/rev/
> 8affe6e83188787eb61fe0528eeb6eef6081ba06/browser/locales/en-US/browser/
> preferences/preferences.ftl#430-433

Yes, that sounds like a good idea.
Actually.. why didn't we go with { -brand-short-name } for ftl? hmm...
(In reply to Ed Lee :Mardak from comment #7)
> Actually.. why didn't we go with { -brand-short-name } for ftl? hmm...

I was thinking exactly the same. brand.ftl was added in bug 1424683, which landed over a month before that string, so it was available.

For now, we should use "&brandShortName;" in this patch instead of "Firefox", and drop the comment (sorry for the 180° turn).
Attached image v1.1 screenshot
Attachment #8979326 - Attachment is obsolete: true
Comment on attachment 8979329 [details]
Bug 1396839 - "Nightly Start Page" tooltip is displayed for "Home" button when Activity Stream overrides about:home.

https://reviewboard.mozilla.org/r/245504/#review251522

In the meantime, I've realized why it makes sense for preferences to use 'Firefox' hard-coded: talking about "Firefox Home" makes more sense than "Nightly Home".

Having said that, this looks good to me, given it's a tooltip. Unless the lack of consistency with prefs (or having "Nightly Home Page") is a problem for UX.
Attachment #8979329 - Flags: review?(francesco.lodolo) → review+
Comment on attachment 8979329 [details]
Bug 1396839 - "Nightly Start Page" tooltip is displayed for "Home" button when Activity Stream overrides about:home.

https://reviewboard.mozilla.org/r/245504/#review251520
Attachment #8979329 - Flags: review?(felipc) → review+
Pushed by edilee@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0c033165b03f
"Nightly Start Page" tooltip is displayed for "Home" button when Activity Stream overrides about:home. r=Felipe,flod
https://hg.mozilla.org/mozilla-central/rev/0c033165b03f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Iteration: --- → 62.2 - Jun 4
The issue is no longer reproducible on the latest Nightly 62.0a1 (Build ID 20180605220158) on Windows 10 x64, Mac 10.13.3 and Arch Linux x64. The string is now <Product> Home Page.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.