Open Bug 1396925 Opened 4 years ago Updated 4 years ago

Support for must-staple missing in certificate details dialogue

Categories

(Core :: Security, enhancement, P3)

55 Branch
enhancement

Tracking

()

People

(Reporter: kloucekm, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

Look at a must-staple certificate, for example at https://blog.cloudflare.com/
Switch to "Details"
Scroll down to "Object Identifier (1 3 6 1 5 5 7 1 24)"


Actual results:

I see "Object Identifier (1 3 6 1 5 5 7 1 24)" and IDs of supported TLS extensions


Expected results:

I would like to see "TLS Features" and names of supported TLS extensions.
A better name would be "Certified TLS features", but I cannot argue with a RFC.
Summary: Thanks for implementing "must-staple". It would be great if you could also find time to implement the support in the "certificate details dialogue", instead of showing "1.3.6.1.5.5.7.1.24" and TLS extension names instead of their ID. → Support for "must-staple" missing in "certificate details dialogue"
Summary: Support for "must-staple" missing in "certificate details dialogue" → Support for "must-staple" missing in certificate details dialogue
Summary: Support for "must-staple" missing in certificate details dialogue → Support for must-staple missing in certificate details dialogue
Depends on: 901698
Component: Untriaged → Security
Product: Firefox → Core
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.