Missing buttons if build on 10.13

RESOLVED FIXED

Status

()

P5
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Nomis101, Unassigned)

Tracking

unspecified
All
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox57 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8904667 [details]
Screenshot of issue

If FF/TB is build on 10.13, than the red/yellow/green buttons in the left corner are missing. This has nothing to do with the SDK, tested with 10.11, 10.12 and 10.13 SDK, all the same issue.
If you get (In reply to Nomis101 from comment #0)
> This has nothing to do with the SDK, tested with 10.11,
> 10.12 and 10.13 SDK, all the same issue.

Can you check whether the build at https://queue.taskcluster.net/v1/task/N-CI_f3CRJ2IBMXfRBKTcg/runs/0/artifacts/public/build/target.dmg also shows this issue when run on 10.13? (I would check myself but I don't have access to 10.13 at the moment.)
That's a build from a try push from bug 1324892, but compiled on Linux. I wonder if this is really caused by building on 10.13, or if a 10.11+ SDK is enough to cause it.
(Reporter)

Comment 2

a year ago
(In reply to Markus Stange [:mstange] from comment #1)
> If you get (In reply to Nomis101 from comment #0)
> > This has nothing to do with the SDK, tested with 10.11,
> > 10.12 and 10.13 SDK, all the same issue.
> 
> Can you check whether the build at
> https://queue.taskcluster.net/v1/task/N-CI_f3CRJ2IBMXfRBKTcg/runs/0/
> artifacts/public/build/target.dmg also shows this issue when run on 10.13?
> (I would check myself but I don't have access to 10.13 at the moment.)
> That's a build from a try push from bug 1324892, but compiled on Linux. I
> wonder if this is really caused by building on 10.13, or if a 10.11+ SDK is
> enough to cause it.

This build is not showing the issue for me.
Thing is, I was able to build normally on 10.12. I have this issue since updated to 10.13 and my mozconfig did not change. In the meantime I found out, it is a combination of 10.13 and the SDK. I see the issue on all SDKs from 10.10 SDK to 10.13 SDK. But if I build with the 10.9 SDK, this fixes the issue.
Thanks! So this affects building on 10.13 only. Since our build machines aren't going to be upgraded to 10.13 anytime soon, this shouldn't block bug 1379811.
No longer blocks: 1379811
status-firefox57: --- → fixed
OS: Unspecified → Mac OS X
Priority: -- → P5
Hardware: Unspecified → All
status-firefox57: fixed → wontfix
(Reporter)

Comment 4

a year ago
I confirmed that this bug is fixed on trunk. I was also able to fix it in 56 by applying locally all "10.13 patches". So, one of this patches has fixed this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.