Screen sharing window list isn't updated on Windows 7

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: pablo.platt, Unassigned)

Tracking

55 Branch
Unspecified
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needinfo to reporter 2017-09-07])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

The window list in the screen sharing popup isn't updated until closing Firefox.
Tested on Windows 7.

1. Open a window to share, e.g. Calculator.
2. Go to https://mozilla.github.io/webrtc-landing/gum_test.html
3. Click on the Window button in the demo.
4. Select the Calculator window and click Allow.
5. Close the Calculator window.
6. Refresh the demo page.
7. Click on the Window button.


Actual results:

The Calculator window is still on the list.


Expected results:

The Calculator window shouldn't be on the list after it was closed.
Opening the popup again and even refreshing the browser doesn't help. The list is updated only when closing Firefox.

The list should update every time a window is open, closed or its title is changed. Maybe there is an event for that on Windows or Firefox might use polling.
(Reporter)

Updated

a year ago
Summary: screen sharing window → Screen sharing window list isn't updated on Windows 7
Component: Untriaged → WebRTC: Audio/Video
OS: Unspecified → Windows 7
Product: Firefox → Core
I could not reproduce in Firefox 57 on Windows 10.

Pablo, do you see the same behavior in Firefox 56/57?
Flags: needinfo?(pablo.platt)
See Also: → bug 1041369
Whiteboard: [needinfo to reporter 2017-09-07]
(Reporter)

Comment 2

a year ago
I can't reproduce in Firefox 56 on Windows 7.
Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(pablo.platt)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.