Closed Bug 1397037 Opened 3 years ago Closed 3 years ago

Crash in RtlEnterCriticalSection | nsInputStreamPump::Resume

Categories

(Core :: Networking, defect, P1, critical)

56 Branch
x86
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1396307
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- fix-optional
firefox57 --- fixed

People

(Reporter: philipp, Assigned: valentin)

References

Details

(Keywords: crash, regression, Whiteboard: [necko-active])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-afa97097-6ca8-4b30-9fe6-be8140170905.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	ntdll.dll 	RtlEnterCriticalSection 	
1 	xul.dll 	nsInputStreamPump::Resume() 	netwerk/base/nsInputStreamPump.cpp:244
2 	xul.dll 	mozilla::net::nsHttpChannel::OnAuthAvailable() 	netwerk/protocol/http/nsHttpChannel.cpp:5791
3 	xul.dll 	mozilla::net::nsHttpChannelAuthProvider::ContinueOnAuthAvailable(nsACString const&) 	netwerk/protocol/http/nsHttpChannelAuthProvider.cpp:1506
4 	xul.dll 	mozilla::net::nsHttpChannelAuthProvider::OnAuthAvailable(nsISupports*, nsIAuthInformation*) 	netwerk/protocol/http/nsHttpChannelAuthProvider.cpp:1368
5 	xul.dll 	NS_InvokeByIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_msvc.asm:54
6 	xul.dll 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp:1282
7 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:967
8 	xul.dll 	js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp:469
9 	xul.dll 	InternalCall 	js/src/vm/Interpreter.cpp:514
10 	xul.dll 	Interpret 	js/src/vm/Interpreter.cpp:3064
11 	xul.dll 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp:409
12 	xul.dll 	js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp:487
13 	xul.dll 	InternalCall 	js/src/vm/Interpreter.cpp:514
14 	xul.dll 	JS_CallFunctionValue(JSContext*, JS::Handle<JSObject*>, JS::Handle<JS::Value>, JS::HandleValueArray const&, JS::MutableHandle<JS::Value>) 	js/src/jsapi.cpp:2890
15 	xul.dll 	nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) 	js/xpconnect/src/XPCWrappedJSClass.cpp:1215
16 	xul.dll 	nsXPCWrappedJS::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) 	js/xpconnect/src/XPCWrappedJS.cpp:615
17 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/md/win32/xptcstubs.cpp:85
18 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/md/win32/xptcstubs.cpp:112
19 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1446

this crash signature is newly showing up during the 56.0b cycle.
This looks similar to bug 1396307.  Valentin, could you take a look at it?
Flags: needinfo?(valentin.gosu)
See Also: → 1396307
Assigning to myself. Likely the same as bug 1396307, but will verify independently after we land a fix.
Assignee: nobody → valentin.gosu
Flags: needinfo?(valentin.gosu)
Whiteboard: [necko-active]
I see a few crashes in 57 as well.
Bulk priority update: https://bugzilla.mozilla.org/show_bug.cgi?id=1399258
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1396307
You need to log in before you can comment on or make changes to this bug.