Instead of "enter", "." causes the browser to go to what is typed in the address bar

RESOLVED WORKSFORME

Status

SeaMonkey
Location Bar
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: carl, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    20022041711

If I type an address in the address bar, such as "www.google.com", and press
"enter" nothing will happen.  however, after, if I press ".", it will go to the
URL: www.google.com. -- which, of course, does not exist.    In addition, if I
try to erase the original www.google.com, and start typing again, when I get as
far as www. the browser will open the webpage  known as "www.www.com".  For no
apparent reason, however, the address bar works like normal on rare occasions.

Reproducible: Always
Steps to Reproduce:
1.type in an address in the address bar
2.try pressing "enter"--the icon is greyed out and nothing happens
3.start typing something else until you hit the "." button, 

Actual Results:  it goes to whatever is typed in the address bar

Expected Results:  it should not have gone anywhere until I pressed "enter"

the only workaround i can find for this is going to "file" and then "open web
location", which seems to work.

Comment 1

16 years ago
When did this problem start?  After you upgraded?  If you upgraded, did you 
first delete your existing installation?
(Reporter)

Comment 2

16 years ago
Yes, I had just upgraded when I noticed the problem.  After uninstalling mozilla
and re-installing it, however, the problem went away.  That seems to be an easy
fix.  

Comment 3

16 years ago
This is sort of related to the anomalities that happen in bug 135222...
basically, installing a newer version over an existing version of Mozilla is BAD.
Latest installers should prompt you to first delete your existing Mozilla
directory before proceeding with the upgrade.

Since we know the problem now, I will go ahead and resolve the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → LATER
LATER is deprecated per bug 35839.
Status: RESOLVED → UNCONFIRMED
Resolution: LATER → ---
WFM per the above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.