Crash in mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::dom::PContentChild::SendPURLClassifierLocalConstructor

RESOLVED FIXED in Firefox 57

Status

()

P1
critical
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: calixte, Assigned: tnguyen)

Tracking

(Blocks: 1 bug, {crash, regression})

57 Branch
mozilla57
Unspecified
Windows 10
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Whiteboard: [clouseau], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-bfcbdb86-c503-4d1e-9c5f-912ce0170905.
=============================================================

There are 3 crashes in nightly 57 with buildid 20170905100117. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1345058.

[1] https://hg.mozilla.org/mozilla-central/rev?node=e29cf8ae2c4641886cf75eb7509edf59c511ceb1
Flags: needinfo?(tnguyen)
Priority: -- → P1
Thomas, this bug is critical and urgent.
Could you look into it ASAP?
(Assignee)

Updated

a year ago
Assignee: nobody → tnguyen
Flags: needinfo?(tnguyen)
(Reporter)

Updated

a year ago
Crash Signature: [@ mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::dom::PContentChild::SendPURLClassifierLocalConstructor] → [@ mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::dom::PContentChild::SendPURLClassifierLocalConstructor] [@ mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::ipc::IProtocol::HandleFatalError | mozilla::ipc::IProt…
Comment hidden (mozreview-request)
(Assignee)

Comment 3

a year ago
It looks like the problem happens in shutdown. I see we check ContentChild::IsShuttingDown before doing a send in many places, it's appropriate to do something the same here.
(Assignee)

Updated

a year ago
Status: NEW → ASSIGNED

Comment 4

a year ago
Another one of these IPC crashes during shutdown...

Comment 5

a year ago
mozreview-review
Comment on attachment 8905407 [details]
Bug 1397231 - Skip new URLClassifierLocalChild when ContentChild is shutting down

https://reviewboard.mozilla.org/r/177212/#review182376
Attachment #8905407 - Flags: review?(ehsan) → review+

Comment 6

a year ago
Pushed by tnguyen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f41d54eddd16
Skip new URLClassifierLocalChild when ContentChild is shutting down r=Ehsan

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f41d54eddd16
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.