Closed Bug 1397235 Opened 3 years ago Closed 3 years ago

Crash in mozilla::image::ImageSurfaceCache::SuggestedSize

Categories

(Core :: ImageLib, defect, critical)

57 Branch
Unspecified
Windows 10
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: calixte, Assigned: aosmond)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [clouseau])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-1a9cbcf7-bf56-4650-9847-66b180170906.
=============================================================

There are 18 crashes in nightly 57 with buildid 20170905220108. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1370412.

[1] https://hg.mozilla.org/mozilla-central/rev?node=536e6a1d3b4f990917a5d97765b29b25180512b7
Flags: needinfo?(aosmond)
Crash Signature: [@ mozilla::image::ImageSurfaceCache::SuggestedSize] → [@ mozilla::image::ImageSurfaceCache::SuggestedSize] [@ mozilla::image::ImageSurfaceCache::SuggestedSize const]
I think I see the problem. Will fix.
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Component: Graphics → ImageLib
Attachment #8905040 - Flags: review?(tnikkel)
Add the signature 'mozilla::WrapNotNull<T>' because the previous function in the backtrace is mozilla::image::ImageSurfaceCache::SuggestedSize (it's only present on FennecAndroid).
Crash Signature: [@ mozilla::image::ImageSurfaceCache::SuggestedSize] [@ mozilla::image::ImageSurfaceCache::SuggestedSize const] → [@ mozilla::image::ImageSurfaceCache::SuggestedSize] [@ mozilla::image::ImageSurfaceCache::SuggestedSize const] [@ mozilla::WrapNotNull<T>]
Attachment #8905040 - Flags: review?(tnikkel) → review+
Pushed by philringnalda@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/354981c2ee1f
Ensure that we reset factor-of-2 mode for an ImageSurfaceCache when it becomes empty. r=tnikkel
https://hg.mozilla.org/mozilla-central/rev/354981c2ee1f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
No more crashes with these signatures on Socorro.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.