Closed Bug 1397241 Opened 3 years ago Closed 3 years ago

[LeanPlum] Push notification - Install Pocket displayed even if the app is already installed

Categories

(Firefox for Android :: General, defect)

57 Branch
ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox57 --- verified

People

(Reporter: sflorean, Unassigned)

References

(Blocks 1 open bug)

Details

Device: Honor 8 (Android 7.0);
Build: 57.0a1;

Prerequisites:
 - install Switchboard:Experiments and enable LeanPlum
 - install Pocket 

Steps to reproduce:
 1. After finishing setting up Fennec open a bookmark.
 2. Wait for Campaign A to trigger.

Expected result:
 After a 5 minute period for each push (PN1, PN2, PN3), the PN4 (push notification 4) from campaign A is not displayed.

Actual result:
 After a 5 minute period for each push (PN1, PN2, PN3), the user received Pocket PN4 (push notification 4) from campaign A.
I just reset A1~A4.
Please note. If the user didn't start Fennec after the installation, Leanplum won't receive this information. Thus we won't know if the user has already installed Pocket.
Two points here:

1. About the requirement. Do we expect only the users "without Pocket installed" will get the notification? (just send a mail to confirm w/ Marketing and you are cc-ed, too) If yes Nevin has update A1~A4 as comment 1, would you help check again?

2. About test steps. Since "Pocket install" is checked when App launch, you need to launch (restart) Feneec after Pocket installation. (not sure if that's the case in your initial test?)

Thanks.
Flags: needinfo?(sorina.florean)
(In reply to Wesly Huang (Fennec Frontend/Firefox EPM) from comment #2)
> Two points here:
> 
> 1. About the requirement. Do we expect only the users "without Pocket
> installed" will get the notification? (just send a mail to confirm w/
> Marketing and you are cc-ed, too) If yes Nevin has update A1~A4 as comment
> 1, would you help check again?

Checked again, and If Pocket app is already installed, the user doesn't receive push notification A1-A4.
If the app is not installed the push notification from campaign A works as expected.

> 2. About test steps. Since "Pocket install" is checked when App launch, you
> need to launch (restart) Feneec after Pocket installation. (not sure if
> that's the case in your initial test?)
Yes, this step was included in my testing too. Sorry for didn't mention in the bug's description.
Flags: needinfo?(sorina.florean)
Thanks, Sorina. Marketing has confirmed "without Pocket installed" is a nice-to-have criterion so we are all good about this bug now! (no matter the initial test result, or the retest result w/ Nevin's setting update)
Mark this as verified. The issue was fixed and is not reproducible.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.