Closed Bug 1397245 Opened 3 years ago Closed 2 years ago

[LeanPlum] - Pocket installation page not opened using Google Play

Categories

(Firefox for Android :: General, defect, P1)

57 Branch
ARM
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox57 --- wontfix
firefox58 --- affected

People

(Reporter: bsurd, Assigned: vlad.baicu)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Leanplum] [61])

Device:
 - Samsung Galaxy Note 4 (Android 5.0.1).

Build:
 - Nightly 57.0a1 (05-Sep-2017);

Prerequisites:
 - install Scitchboard:Experiments and enable LeanPlum

Steps to reproduce:
 1. After finishing setting up Fennec run trough Campaign A PN;
 2. Wait for Campaign A PN4 to trigger;
 3. Tap on the Notification.

Expected result:
 Pocket installation page opens in GooglePlay App.

Actual result:
 Pocket installation page is opened in a new tab in Nightly.

Notes:
 On all other devices I've tested the push notification opened the pocket installation page using Google Play.
I guess this is device specific issue. Do we have a device to test?
Flags: needinfo?(wehuang)
No I don't think we have the device here.

Bogdan, just to be sure, from your Note in comment 0, it behaves correctly for most of the devices, except Note 4? (works in any other Samsung devices you have?)
Flags: needinfo?(wehuang) → needinfo?(bogdan.surd)
Hello,

No it's not a Note only issue its the same for every Android device that has and Android version lower than 5, devices with Android 6+ open the app in the Play Store App and devices with Android 5 and lower open it in Fennec. 

This is not a big concern, filed this issue to see if there is any way around this so that all users are redirected from the Notification to the Play Store App installation page for Pocket regardless of their Android OS.
Flags: needinfo?(bogdan.surd)
Thanks, Bogdan. Just found you did mention it in the offline email discussion. Nevin may further check this but agree with you it's anyway not a blocker.

Nevin, maybe you can double check if this is the Android limitation? Thanks.
Flags: needinfo?(cnevinchen)
Looking at the SDK code, in Android 8 Play Store will intercept the play store URL. So we didn't use our browser to handle the intent. So to your question, yes.
Flags: needinfo?(cnevinchen) → needinfo?(wehuang)
thanks, then P3 is enough.
Flags: needinfo?(wehuang)
Priority: -- → P3
Given that this was triaged as a P3, I don't think we'll see this fixed in 57. Tagging 58 as affected.
[triage] Bulk edit: product thinks leanplum is high priority: P1 rank 1.
Assignee: cnevinchen → nobody
Rank: 1
Priority: P3 → P1
Whiteboard: [Leanplum]
Whiteboard: [Leanplum] → [Leanplum] [61]
Assignee: nobody → vlad.baicu
This seems like a preference setting in newer versions of Android rather than a bug.

On newer versions of Android you can go to Settings -> Apps -> Google Play Store -> Open by default and explicitly set if you want the Store app to intercept the all store urls by the app and open them there directly or treat them just like any other urls.

I'm not sure we should intervene with this as it is something related to the user's preference. Michael, what do you think ?
Flags: needinfo?(michael.l.comella)
I think we explicitly made it so links open in Firefox first and the user needs to click the page action (in the URL bar) in order to open apps (I think because this protects user privacy).

Vlad, have you looked into how this URL is loaded and if it goes through the regular fennec load url code path? If so, we might be intercepting the load play store URL event before it even gets to the system (and the settings you mention). If that's the case, we could probably just use a different code path to load the intent directly rather than using the fennec load url code.
Flags: needinfo?(michael.l.comella)
On the tests I've run , the notification intent doesn't even reach the LauncherActivity on devices running Android > 5, it gets intercepted by the play store app directly. Do we want to always open play store urls directly in fennec and look for a way to bypass this behavior ?
Flags: needinfo?(michael.l.comella)
> Do we want to always open play store urls directly in fennec and look for a way to bypass this behavior ?

Unfortunately, I don't know the code well enough to know whether this is a good idea or not: my intuition leans towards not sending this Leanplum event directly through our standard loadUrl code paths because it overcomplicates a simple problem that only needs to send an intent.
Flags: needinfo?(michael.l.comella)
This is another issue I need to discuss with Kat.
Flags: needinfo?(kplam)
Flags: needinfo?(kplam) → needinfo?(cpark)
Cherry, FYI, the product ask here is whether we want to open play store URLS in the Play Store or always open them in Fennec. Alno NI'ing Andreas here as he may have to make a decision.
Flags: needinfo?(abovens)
I'd be fine with sending Play Store URLs (play.google.com / market.android.com) directly to the Play Store app (unless the user has picked a different option in Settings -> Apps -> Google Play Store), given that it really is a fundamental part of the Android OS. There's little point in intercepting those URLs and loading them in the browser first.
Flags: needinfo?(abovens)
Thanks Andreas! So Petru do we have to do work to support Andreas’ preference?
Flags: needinfo?(petru.lingurar)
Currently, on versions of Android higher than 5, all play store urls get intercepted by the play store app and opened there if the preference is enabled (which is enabled by default). In my opinion everything works as intended and we can close the issue.
Flags: needinfo?(petru.lingurar)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Sounds good. Will clear on our end as an outstanding issue as well.
Flags: needinfo?(cpark)
You need to log in before you can comment on or make changes to this bug.