mach bootstrap should not overwrite a newer rustup

RESOLVED DUPLICATE of bug 1385241

Status

RESOLVED DUPLICATE of bug 1385241
a year ago
8 months ago

People

(Reporter: mconley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
In bug 1397279, we noticed that rustup was installing 0.2.0 over top of 1.6.0.

Ignoring the fact that 0.2.0 is way out of date and shouldn't be installed (bug 1397279 kicks the can down the road on that one), we should probably _not_ be overwriting a newer version of rustup if one already exists.
I looked into something similar recently, bug 1385241 comment 5 has the details. We have solid Rust bootstrap installation code that's used on other platforms, but the Mozillabuild bootstrapper has its own and it doesn't do as good of a job.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385241

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.