Closed Bug 1397487 Opened 4 years ago Closed 4 years ago

Let user pick a sidebar that's open by default on startup

Categories

(WebExtensions :: Untriaged, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1385630

People

(Reporter: botond, Unassigned)

Details

The WebExtension way for extensions to provide vertical tabs or tree tabs is to use a custom sidebar.

However, AFAICT, sidebars currently have the property that they are not open by default, and you have to open them every time you launch the browser. That doesn't fit the use case of a replacement tab bar well, because a tab bar is something you expect to be visible all the time.

I would suggest adding a way for the user to choose a sidebar that is open by default when the browser starts.
When a user chooses a side bar, such as a WebExtension, bookmark or whatever, that should be respected by Firefox on start up. I believe that's bug 1385630. I don't believe a WebExtension API should be overriding the user choice in this matter.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385630
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.