Mark Selected Links As Visited 0.3 can hang the browser

RESOLVED WORKSFORME

Status

()

Toolkit
Places
RESOLVED WORKSFORME
3 months ago
2 months ago

People

(Reporter: asa, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(URL)

(Reporter)

Description

3 months ago
The extension Mark Selected Links As Visited 0.3 available at https://addons.mozilla.org/en-US/firefox/addon/mark-selected-links-as-visited hangs the browser about half the time I use it.

Steps to reproduce:
1. install extension
2. visit https://www.reddit.com/
3. click the button to mark all links on the page as visited

Results: 
About half the time the whole browser hangs. Some of the time I can still switch tabs but none of them will load a web page. 

Expected results: links marked visited and no hanging.
This works fine for me, but of the main thread execution time that it causes, nearly all of it is in Places.
Component: WebExtensions: Untriaged → Places

Comment 2

2 months ago
This needs a stack or a https://perf-html.io/ profile.

Off-hand doesn't look like this should cause much main-htread stuff, it's just adding a visit. I wonder if something else is listening to history changes and slowing down everything, maybe another add-on or a test pilot.
(Reporter)

Comment 3

2 months ago
I've been unable to reproduce this recently and it was intermittent before and now it seems gone.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.