View source on POSTed page gives different source to displayed

VERIFIED DUPLICATE of bug 55583

Status

--
major
VERIFIED DUPLICATE of bug 55583
17 years ago
8 years ago

People

(Reporter: greg.webb, Assigned: doronr)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Hit while doing some intranet development. Sorry if this is a duplicate, can't
find a previous bug listing this.

Let's say I have a page which is generated from POST data. When I try to view
its source, the source shown is clearly different to that displayed. In fact, it
appears that it's submitted a new request without the data because it's
displaying a server error which would match the page being called without input
data.

Reproducible: Always
Steps to Reproduce:
1. Find page which POSTs data to another page, which then outputs HTML based on
that POSTed data.
2. POST some data using the above page.
3. When the new page appears (showing its data correctly on the screen), right
click on the page and select 'View Page Source'.
4. Parse the HTML manually. Over here, it's showing error messages corresponding
to the page not having been given any input to generate its data from.

Actual Results:  I got an error message back, legit and error source listed below.

Error:

 <font face="Arial" size=2>
<p>ADODB.Field</font> <font face="Arial" size=2>error '800a0bcd'</font>
<p>
<font face="Arial" size=2>Either BOF or EOF is True, or the current record has
been deleted; the operation requested by the application requires a current
record.</font>
<p>
<font face="Arial"
size=2>/fife/cms/cmsfiles/LearningZone/admin/reports/byuser_rep.asp</font><font
face="Arial" size=2>, line 16</font>

Legit:



<html>
<head>
  <title>Report By User - Admin Area</title>
  <style>
    A{color:808080; text-decoration:none}
    A:hover {color: #FF0000}
  </style>
</head>
<body bgcolor="white">
<div align="left">
<table border="0" width="776" height="346">
<tr>
  
<td width="200" rowspan="3"><img border="0" src="images/logo.gif"></td>
  <td width="617" height="31">
    <p align="center"><b><font face="Arial">On-Line e-learning Management &amp;
Reporting Platform</font></b>
  </td>
</tr>
<tr>
  <td width="617" height="11">
    <p align="center"><font face="Arial" size="2"><b>Materials selected by User:
Graham Cruickshanks</b></font>
  </td>
</tr>
<tr height="30">
  <td width="617" height="30">
    <p align="center"><font face="Arial" size="2"><b>Report run on:&nbsp;24
April 2002 at: 3:38:18 PM</b></font>
  </td>
</tr>
<tr>
  
  <td width="776" height="60" colspan="2">&nbsp;
    <p><font face="Arial" size="2"><b>Report for User:</b> Graham
Cruickshanks</font></p> <font face=arial size=2>Sorry, this user has not
selected any materials</font>
<p></tr>
</table>
</div>
<p><font size="2" face="Arial"><a href="default.asp">Click here to return to
reports menu</a></font></p>
<div align="left">
<table border="0" width="349" height="8">
<tr>
  <td width="349" height="18" bordercolor="#FFFFFF" bgcolor="#CCCCCC"><font
size="1" face="Arial" color="#000080">Report 
    generated by the e-learning Support &amp; Management Platform</font></td>
</tr>
</table>
</div>
</body>
</html>


Expected Results:  Should have displayed the correct source shown above (which
it had downloaded to display the page) as opposed to submitting a new request.
The new request may initiate an undesirable server action, while it definitely
shouldn't happen with POST data that doesn't match what was originally sent...

If needed, give me a yell and I'll create a quick example site which shows this
problem.

Severity listed below is from my POV as a web developer. This isn't a user
problem really, but can be a killer for a developer and may break some sites in
a _really_ odd way.

Comment 1

17 years ago
Greg:

This bug was imho fixed some builds ago..

Could you try a newer build? this is sure a dup (..of a fixed bug)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
Thanks guys, hadn't spotted the bug you've marked me as a duplicate of.

Have to say, though, I'm running 0.9.9... Short of nightlies and RCs I believe
this is the most current release of Moz? Definitely showing up here with that
and this is a work box so I'm a little nervous about sticking on a nightly build.
> Have to say, though, I'm running 0.9.9... Short of nightlies and RCs I believe
> this is the most current release of Moz? Definitely showing up here with that

Correct on all counts.  :)  The bug was fixed after 0.9.9 branched and the only
builds available so far with the fix are nightlies and RC1.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.