Closed Bug 1397721 Opened 2 years ago Closed 2 years ago

[cross-channel] Build beta from l10n-central

Categories

(Release Engineering :: Release Automation: Other, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Pike, Assigned: Callek)

References

(Blocks 1 open bug)

Details

Attachments

(6 files, 1 obsolete file)

When we do cross-channel l10n, we'll use the l10n-central repositories to localize the affected channels.

The actual cross-channel setup will ride the trains, so if we're making 57, we'll want all of 57 to build from l10n-central.

This doesn't affect sign-offs, they'll still be needed and wanted, and we'll provide the data at the usual URLs.

I know that we'll need to edit the in-tree data, which is easy.

But I also found a couple of references in https://dxr.mozilla.org/build-central/search?q=releases%2Fl10n%2Fmozilla-beta&redirect=false

If we're making 57 depends on us having the underlying infrastructure, like the generated en-US repository, and an OK way to update it. Those items are tracked in bug 1397720.

If we make 57, we'll want this to be in-tree (and wherelse needed) by the merge on the 14th.
Comment on attachment 8905477 [details]
bug 1397721, build from l10n-central instead of releases/l10n/mozilla-beta for cross-channel l10n,

https://reviewboard.mozilla.org/r/177290/#review183940

missing the android *.json entries in https://dxr.mozilla.org/mozilla-central/search?q=l10n%2Fmozilla-beta
Attachment #8905477 - Flags: review-
Comment on attachment 8905478 [details]
bug 1397721, build from l10n-central instead of releases/l10n/mozilla-release for cross-channel l10n,

https://reviewboard.mozilla.org/r/177292/#review183942

r- for the same reason as the first patch, though I would put a cautionary comment in https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/configs/single_locale/mozilla-esr52.py to alert whoever is prepping the next ESR cycle that we should use l10n central for cross channel (or maybe to consult l10n team on if we want cross-channel l10n for the next esr).
Attachment #8905478 - Flags: review-
This patch can land now, and flips the config entry for BB
Attachment #8907271 - Flags: review?(kmoir)
Attached patch Beta Patch for 57 Merge day (obsolete) — Splinter Review
This patch must land on merge day before the first 57 beta
Attachment #8907272 - Flags: review?(kmoir)
This patch must land once we're ready to GTB for 57.0
Attachment #8907274 - Flags: review?(kmoir)
Comment on attachment 8905477 [details]
bug 1397721, build from l10n-central instead of releases/l10n/mozilla-beta for cross-channel l10n,

https://reviewboard.mozilla.org/r/177290/#review184408
Attachment #8905477 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 8905478 [details]
bug 1397721, build from l10n-central instead of releases/l10n/mozilla-release for cross-channel l10n,

https://reviewboard.mozilla.org/r/177292/#review184412
Attachment #8905478 - Flags: review?(bugspam.Callek) → review+
Pushed by axel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1fef4a3d0683
build from l10n-central instead of releases/l10n/mozilla-beta for cross-channel l10n, r=Callek
https://hg.mozilla.org/integration/autoland/rev/659c80698229
build from l10n-central instead of releases/l10n/mozilla-release for cross-channel l10n, r=Callek
Keywords: leave-open
Attachment #8907271 - Flags: review?(kmoir) → review+
Attachment #8907272 - Flags: review?(kmoir) → review+
Attachment #8907274 - Flags: review?(kmoir) → review+
Comment on attachment 8907272 [details] [diff] [review]
Beta Patch for 57 Merge day

Review of attachment 8907272 [details] [diff] [review]:
-----------------------------------------------------------------

I'm going to split this patch, turns out we'll be doing a beta 56 of fennec *after* we kick a beta 57 of devedition, so we need this to land seperately.
Kim already reviewed this change, so r+ and just splitting the patch.
Assignee: nobody → bugspam.Callek
Attachment #8907272 - Attachment is obsolete: true
Attachment #8907886 - Flags: review+
Kim already reviewed
Attachment #8907887 - Flags: review+
Summary:

* I'm landing https://bugzilla.mozilla.org/attachment.cgi?id=8907271 now
* https://bugzilla.mozilla.org/attachment.cgi?id=8907886 is needed by the first TB beta based on 57.
* https://bugzilla.mozilla.org/attachment.cgi?id=8907887 can only land after the last 56 beta, and before the first fennec 57 beta.
* for next merge day (57 to release) need to land https://bugzilla.mozilla.org/attachment.cgi?id=8907274

After I land that first one, I'll add the details into releasewarrior.
Comment on attachment 8907271 [details] [diff] [review]
Patch to flip the basic config entry for Buildbot r=kmoir

Review of attachment 8907271 [details] [diff] [review]:
-----------------------------------------------------------------

https://hg.mozilla.org/build/buildbot-configs/rev/618145e94126563ef918b2387c43f7afd69bca99
Attachment #8907271 - Flags: checked-in+
Johan, FYI there are patches here that need to be reconfig'd before GTB's come in, see https://github.com/mozilla/releasewarrior/commit/fc94fa73720955c15a5b40bc92d5a31dd78ffbf7
Flags: needinfo?(jlorenzo)
Blocks: 1384626
Thanks for the heads up. Callek and I discussed this on IRC. We don't think Fennec 56.0b13 will be impacted by the reconfigs, because changesets are defined in-tree. There might be some wrong behavior on the mozharness side. I'll keep an eye on it, next week.

:Pike just confirmed over email that l10n-central was indeed used in release-promotion. This is the case in [1], for instance.

[1] https://archive.mozilla.org/pub/devedition/tinderbox-builds/mozilla-beta-l10n/release-mozilla-beta_devedition_linux_l10n_repack-bm74-build1-build134.txt.gz
Flags: needinfo?(jlorenzo)
See Also: → 1403084
Callek, can this be closed?  Lizzard was pinging me about the state of the bug it blocks and this bug is still listed as open.
Flags: needinfo?(bugspam.Callek)
Indeed it can
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(bugspam.Callek)
Resolution: --- → FIXED
See Also: → 1414939
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.