a=ssrc is added in an recvonly answer

RESOLVED INVALID

Status

()

Core
WebRTC: Signaling
RESOLVED INVALID
11 months ago
10 months ago

People

(Reporter: Francesco Durighetto, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needinfo 2017-09-12 drno] )

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

Create a peerconnection from chrome to firefox where chrome is a sendonly and firefox is a recvonly


Actual results:

Chrome sent a sendonly sdp and firefox replied with a recvonly sdp.
Firefox also added an a=ssrc for each m=audio and m=video


Expected results:

Is this correct? shouldn't be any a=ssrc since this is a recv only peerconnection?

For more details: https://github.com/webrtc/adapter/issues/674

Updated

11 months ago
Component: Untriaged → WebRTC
Product: Firefox → Core

Comment 1

10 months ago
:drno, what do you think about this?
Component: WebRTC → WebRTC: Signaling
Flags: needinfo?(drno)

Updated

10 months ago
Whiteboard: [needinfo 2017-09-12 drno]

Comment 2

10 months ago
This is valid, yes. Signaling the recvonly SSRC is important because that appears in receiver reports, and we want to be able to demux those when using bundle.

Comment 3

10 months ago
Once everyone is supporting RTP MID, we won't need to signal this, or any other SSRC for that matter.

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(drno)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.