Composer adds %20 to blank spaces in new web page names

VERIFIED DUPLICATE of bug 141819

Status

--
trivial
VERIFIED DUPLICATE of bug 141819
17 years ago
14 years ago

People

(Reporter: susiew, Assigned: cmanske)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: publish ui[FIX IN HAND][reviewed])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
If I create and save a file in Composer such as "susie home" and then go to edit
the file, Composer displays it as "susie%20home.html" when publishing. When I
look at my files it is saved with a blank space as intended. 

This is confusing. 

If Composer needs to add characters to connect the words it should add an
underscore like susie_home.html -- so that when I'm looking at my files the name
is the same as when I'm publishing. And so that the user does not think that
they will have to distribute URLs that contain %20.

Comment 1

17 years ago
--> brade/cmanske
Assignee: syd → brade

Comment 2

17 years ago
I am able to reproduce this problem on the 04-24 trunk build.

But it seems to me this is related to (if not a dupe of) bug 76799.  

Comment 3

17 years ago
actually I don't think this is a duplicate.  The report is that the file is
saved with a space (unlike 76799 where it is saved with %20) but it is displayed
with %20.

-->cmanske since it's the UI that is showing the escaped version of the filename

(cmanske: you should be able to use NS_UnescapeURL for any url fragments you are
displaying)

Susie--I disagree that it should replace the space with an underscore for
display purposes.  There shouldn't be any need to do that; we should be able to
display it as a space.
Assignee: brade → cmanske
Severity: normal → trivial
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: publish ui
Target Milestone: --- → mozilla1.1alpha
(Reporter)

Comment 4

17 years ago
I agree :-) I assumed there had to be a character in the middle but better to
save it as the user wants it.
(Assignee)

Comment 5

17 years ago
Created attachment 81766 [details] [diff] [review]
patch v1

Very conservative fix: Unescape filename when setting input file value,
but depend on nsIURI and network code to do appropriate "escape" before 
using name to publish.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1
Whiteboard: publish ui → publish ui[FIX IN HAND][need r=,sr=]
Target Milestone: mozilla1.1alpha → mozilla1.0

Comment 6

17 years ago
Comment on attachment 81766 [details] [diff] [review]
patch v1

r=andreww
Attachment #81766 - Flags: review+
(Assignee)

Updated

17 years ago
Whiteboard: publish ui[FIX IN HAND][need r=,sr=] → publish ui[FIX IN HAND][need sr=]

Comment 7

17 years ago
Comment on attachment 81766 [details] [diff] [review]
patch v1

sr=kin@netscape.com
Attachment #81766 - Flags: superreview+

Updated

17 years ago
Whiteboard: publish ui[FIX IN HAND][need sr=] → publish ui[FIX IN HAND][reviewed]
(Assignee)

Comment 8

17 years ago
This fix is no longer a good idea, in my opinion.
I think this issue is subsumed by bug 141819.
We need to do appropriate "unescaping" for all parts of the documenent's URL.


*** This bug has been marked as a duplicate of 141819 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.