Closed Bug 1398109 Opened 2 years ago Closed 2 years ago

Crash in nsPIDOMWindowInner::UpdateWebSocketCount [clone .cold.576]

Categories

(Core :: DOM: Core & HTML, defect, critical)

57 Branch
Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: calixte, Assigned: farre)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [clouseau])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-112e0c77-5e46-48ed-b6d6-19a560170908.
=============================================================

There are 4 crashes (from 3 installs) in nighlty 57 with buildid 20170907220212. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1396368.

[1] https://hg.mozilla.org/mozilla-central/rev?node=9b169fc8b1a7d2a4d9249970bb8298537cf61089
Flags: needinfo?(afarre)
(In reply to Calixte Denizet (:calixte) from comment #0)
> This bug was filed from the Socorro interface and is 
> report bp-112e0c77-5e46-48ed-b6d6-19a560170908.
> =============================================================
> 
> There are 4 crashes (from 3 installs) in nighlty 57 with buildid
> 20170907220212. In analyzing the backtrace, the regression may have been
> introduced by patch [1] to fix bug 1396368.
> 
> [1]
> https://hg.mozilla.org/mozilla-central/
> rev?node=9b169fc8b1a7d2a4d9249970bb8298537cf61089

I think it has. I guess that mTopInnerWindow can be null if we're unlucky.
Assignee: nobody → afarre
Flags: needinfo?(afarre)
Attachment #8905901 - Flags: review?(bkelly) → review+
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/523bfd089269
Check if there is a mTopInnerWindow. r=bkelly
Crash Signature: [@ nsPIDOMWindowInner::UpdateWebSocketCount [clone .cold.576]] → [@ nsPIDOMWindowInner::UpdateWebSocketCount [clone .cold.576]] [@ nsPIDOMWindowInner::UpdateWebSocketCount [clone .cold.574]]
https://hg.mozilla.org/mozilla-central/rev/523bfd089269
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
The fix landed in the 9-09 Nightly, but seems like we're still getting these crashes? For example bp-57efb538-7928-4ab9-a812-77e450170913 is a crash from the 9-12 Nightly.
Flags: needinfo?(afarre)
(In reply to Jim Chen [:jchen] [:darchons] from comment #5)
> The fix landed in the 9-09 Nightly, but seems like we're still getting these
> crashes? For example bp-57efb538-7928-4ab9-a812-77e450170913 is a crash from
> the 9-12 Nightly.

Right, so it's a bit of a mess due to this also being addressed in Bug 1396368. The issue is that initially these crash reports pointed at different things. If we look at bp-00861781-e60b-46f9-a1f2-49e6a0170908, for example, we see that the crash reason is a segfault. In bp-57efb538-7928-4ab9-a812-77e450170913 it's the same assert as in Bug 1396368, and that got a fix landed on central yesterday morning Bug 1396368, comment 15.

This would mean that the fix should be in by 9-13 Nightly, and I see no reports form 9-13 so far. I'll keep an eye on it though. Seems reasonable?
Flags: needinfo?(afarre) → needinfo?(nchen)
Thanks for the explanation!
Flags: needinfo?(nchen)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.