Talos tp6 is running on win stylo-disabled on autoland/inbound but no other talos tests are

RESOLVED FIXED in Firefox 58

Status

Testing
Talos
RESOLVED FIXED
2 months ago
27 days ago

People

(Reporter: rwood, Assigned: jmaher)

Tracking

(Blocks: 1 bug)

Version 3
mozilla58
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 wontfix, firefox58 fixed)

Details

(Whiteboard: [PI:September][stylo])

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
The full set of Talos tests on stylo-disabled (Tsd-e10s) are running on mozilla-central and on try (linux/osx/win). However on autoland/inbound, on windows, 'tp6' is running on stylo-disabled (and no other talos tests).
(Reporter)

Comment 1

2 months ago
:bholley, :jryans, can we remove stylo-disabled tp6 from autoland/inbound, and only have it run on mozilla-central/try, so it is consistent with all the other talos tests?
Flags: needinfo?(jryans)
Flags: needinfo?(bobbyholley)
(In reply to Robert Wood [:rwood] from comment #1)
> :bholley, :jryans, can we remove stylo-disabled tp6 from autoland/inbound,
> and only have it run on mozilla-central/try, so it is consistent with all
> the other talos tests?

Removing it from inbound sounds fine, I believe it was only there because that's how other tp6 runs were configured.  Stylo work doesn't really involve inbound much, so it's not very useful to have.

Autoland is slightly more useful to have for Stylo work, but since we're talking about stylo-disabled runs, we wouldn't expect those to change significantly, so central and try only should be fine here.

If we can, keeping the regular, Stylo enabled Windows tp6 runs enabled for at least autoland would be nice (but it doesn't sound like you are proposing to change those anyway).
Flags: needinfo?(jryans)
If possible, it would make my life marginally easier to keep running them on autoland for the next two weeks up until the merge.

I spend a lot of time looking at graphs like:

https://treeherder.mozilla.org/perf.html#/graphs?timerange=604800&series=autoland,1535525,1,1&series=autoland,1534934,1,1&series=autoland,1535521,1,1&series=autoland,1549461,1,1&series=autoland,1549460,1,1

The extra density of data points from running on autoland is really helpful when trying to figure out if there's a real stylo-specific regression or not.

It's not make-or-break, but if we can delay this cleanup by two weeks I'd prefer that. Getting rid of them on inbound is fine.
Flags: needinfo?(bobbyholley)
(Assignee)

Comment 4

2 months ago
we can definitely wait the 2 weeks
Whiteboard: [PI:September]
Blocks: 1345321
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → wontfix
status-firefox58: --- → affected
status-firefox-esr52: --- → unaffected
Whiteboard: [PI:September] → [PI:September][stylo]
(Assignee)

Comment 5

27 days ago
Created attachment 8912635 [details] [diff] [review]
remove tp6-stylo-disabled from running on autoland/inbound
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8912635 - Flags: review?(rwood)
(Reporter)

Updated

27 days ago
Attachment #8912635 - Flags: review?(rwood) → review+

Comment 6

27 days ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2a0834c4397e
only run tp6 on stylo-disabled for beta/central/try branches. r=rwood

Comment 7

27 days ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2a0834c4397e
Status: ASSIGNED → RESOLVED
Last Resolved: 27 days ago
status-firefox58: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.