Closed Bug 1398180 Opened 2 years ago Closed 3 months ago

getSettings() should include deviceId

Categories

(Core :: WebRTC: Audio/Video, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1537986
Tracking Status
firefox57 --- affected

People

(Reporter: jib, Unassigned)

Details

(Keywords: dev-doc-complete)

Forgot to include deviceId when we added getSettings() in bug 1213517.

STRs:
 1. Open https://jsfiddle.net/jib1/3jrkdc1q/ and share cam+mic

Expected result:

{
  "autoGainControl": false,
  "channelCount": 4,
  "echoCancellation": true,
  "noiseSuppression": true
  "deviceId": "hLSmbVie34mQOuLjqIdBxsaBoK+W0eESXBzeK+78guI="
}
{
  "frameRate": 30,
  "height": 480,
  "width": 640,
  "deviceId": "mSUcE4/pfvfWrrUCKPVgPsqTFtztaQ6T32O9yjs8SOs="
}

Actual result:

{
  "autoGainControl": false,
  "channelCount": 4,
  "echoCancellation": true,
  "noiseSuppression": true
}
{
  "frameRate": 30,
  "height": 480,
  "width": 640
}
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3
Hi, any update to this please?
Rank: 18
Priority: P3 → P2

Hi, any update to this please?

This has been fixed by bug 1537986.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1537986

Documentation updates:

  • Submitted BCD PR 4561
  • Mentioned on Firefox 69 for developers
You need to log in before you can comment on or make changes to this bug.