[WebExtensions] browser.extension.getBackgroundPage(); Does not work from private window.

RESOLVED DUPLICATE of bug 1329304

Status

RESOLVED DUPLICATE of bug 1329304
a year ago
4 months ago

People

(Reporter: karol, Unassigned)

Tracking

57 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170908100218

Steps to reproduce:

Make a sidebar that has script that tries to communicate with a background script using: var bg = browser.extension.getBackgroundPage();
(to add more salt to injury, why isn't it chrome.extension.getBackgroundPage(); ??)


Actual results:

browser.extension.getBackgroundPage(); results "null" in private windows


Expected results:

In Chrome, Vivaldi and Opera there is a checkbox in extensions page that allows this to work in private windows.
In Vivaldi and Chrome it's called: "enable in incognito"
In Opera it's called: "Enable in private mode"

Firefox lacks this possibility making many extensions unusable or impossible to convert from Chrome.
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329304

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.