Closed Bug 1398349 Opened 3 years ago Closed 3 years ago

Library > Downloads Panel > Open Containing Folder button needs better styling

Categories

(Firefox :: Menus, defect, P1, trivial)

57 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified

People

(Reporter: bruce.bugz, Assigned: Gijs)

References

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170903140023

Steps to reproduce:

It has the following issues:

1. If an item has been deleted / moved, the icon is still visible and carries hover styling. Although it has a lower opacity, it shouldn't have any hover background / border because it is disabled. Or may be it should completely disappear for deleted / moved files, like the 'Open Containing Folder' in the dedicated downloads panel does for this case.

2. It looks out of place. No other buttons in Photon have a blue background or a blue border.
Component: Untriaged → Menus
Blocks: 1354155
Severity: normal → trivial
Blocks: 1354532
No longer blocks: 1354155
Whiteboard: [photon-structure][triage]
The item needs to have -moz-appearance: none to avoid getting "native" style Windows hover styling (which hasn't really been updated since Windows 8, which is a separate problem...).
Assignee: nobody → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Iteration: --- → 57.3 - Sep 19
Ever confirmed: true
Flags: qe-verify+
Priority: -- → P1
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
(In reply to Bruce from comment #0)
> 1. If an item has been deleted / moved, the icon is still visible and
> carries hover styling. Although it has a lower opacity, it shouldn't have
> any hover background / border because it is disabled. Or may be it should
> completely disappear for deleted / moved files, like the 'Open Containing
> Folder' in the dedicated downloads panel does for this case.

Let's move this bit to bug 1398468 which has the same complaint but for failed downloads.
QA Contact: gwimberly
Comment on attachment 8907564 [details]
Bug 1398349 - don't use native Windows styling for downloads subview 'open in containing folder' button,

https://reviewboard.mozilla.org/r/179268/#review184382

Nice! Prolly also gets rid of the jumpiness.
Attachment #8907564 - Flags: review?(mdeboer) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3bc5e7610101
don't use native Windows styling for downloads subview 'open in containing folder' button, r=mikedeboer
Duplicate of this bug: 1398346
https://hg.mozilla.org/mozilla-central/rev/3bc5e7610101
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Reproduced this issue using an affected Nightly build 57.01 (2017-09-09).

This is verified fixed on 57 Beta 6 (20171005195903) on the following OSes: Win 10 x64, Mac OS X 10.11 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.