Fix missing title on inspector sidebars tabs created by devtools.panels.elements.createSidebarPane API calls

VERIFIED FIXED in Firefox 57

Status

defect
P1
normal
VERIFIED FIXED
2 years ago
10 months ago

People

(Reporter: rpl, Assigned: rpl)

Tracking

(Blocks 1 bug)

unspecified
mozilla57
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified, firefox58 verified, firefox59 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
This bugzilla issue is a follow up of Bug 1341305, which implemented the initial support for the `devtools.panels.elements.createSidebarPane` API method.

The sidebar tabs created with the API does have the title visible in the menu selector which shows all the tabs available, but the tab title (which is visible is the sidebar width is enough to make the sidebar tab visible) is empty.

The reason for the empty title is a missing "title" property on the React Provider component which wraps the actual ExtensionSidebar component.
(Assignee)

Updated

2 years ago
Assignee: nobody → lgreco
Blocks: 1370525
Status: NEW → ASSIGNED
Depends on: 1341305
Priority: -- → P1
(Assignee)

Updated

2 years ago
Attachment #8906568 - Flags: review?(gl)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8906568 [details]
Bug 1398727 - Fix missing tab title on devtools.panels.elements.createSidebarPane tabs.

https://reviewboard.mozilla.org/r/178312/#review183650
Attachment #8906568 - Flags: review?(gl) → review+

Comment 3

2 years ago
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/8b2640d7338b
Fix missing tab title on devtools.panels.elements.createSidebarPane tabs. r=gl
https://hg.mozilla.org/mozilla-central/rev/8b2640d7338b
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57

Comment 5

a year ago
I can reproduce this issue on Firefox 56.0.2 (20171024165158) under Wind 7 64-bit.

Title on inspector sidebars tabs is not displayed and the next error is displayed:
TypeError: chrome.devtools.panels.elements.createSidebarPane is not a function  devtools_page.js:1:1 

This issue is verified as fixed on Firefox 59.0a1(20171114100042), Firefox 58.0b3 (20171114032831) and Firefox 57.0 (20171112125346) under Wind 7 64-bit and Mac OS X 10.13. 

Please see the attached screenshot.

Updated

a year ago
Status: RESOLVED → VERIFIED

Updated

10 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.