Closed
Bug 139882
Opened 24 years ago
Closed 24 years ago
Unable to encrypt using 512 bit keys.
Categories
(MailNews Core :: Security: S/MIME, defect, P2)
Tracking
(Not tracked)
VERIFIED
DUPLICATE
of bug 150809
People
(Reporter: carosendahl, Assigned: ssaux)
Details
(Keywords: regression)
It is impossible to use a 512 bit key for encrypting a message.
To Reproduce:
-Read a message that was signed using a 512 bit key.
-Reply to the message and select the option to encrypt.
Result:
Error message: "Unable to encrypt message. Please check that you have a valid
email certificate for each recipient. Please check that ... valid and trusted."
Expected Result:
If weak encryption is supported, mail message should be successfully encrypted
and sent. If there is only one recipient of the message, or all recipients use
weak encryption, then the message should be encrypted and sent.
If there is a mix of strong and weak encryption certificates, then a
warning/error should enable the user to correct the situation instantaneously
and continue the sending of the message.
| Reporter | ||
Comment 1•24 years ago
|
||
See bug 134992 for technical details.
| Reporter | ||
Comment 2•24 years ago
|
||
Added regression keyword, upped priority. Obviously works in 4.7x.
| Reporter | ||
Comment 3•24 years ago
|
||
nominating nsbeta1(+)!
Weak encryption should work if users want to use it. We just can't crap out
when someone uses a 512 bit key.
| Reporter | ||
Comment 4•24 years ago
|
||
Better bug
*** This bug has been marked as a duplicate of 150809 ***
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
You need to log in
before you can comment on or make changes to this bug.
Description
•