typo in configure.in for sys/bittypes.h test, should be sys/bitypes.h

RESOLVED FIXED in mozilla1.1alpha

Status

P3
normal
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: tim, Assigned: netscape)

Tracking

Trunk
mozilla1.1alpha
DEC
OSF/1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
(Apologies if this bug has been reported before.  I tried to search bugzilla,
but because of the bug I reported previously, Bug # 94734, searching bugzilla
crashes the 0.9.9 mozilla I'm running).

For the first time, I'm attempting to build mozilla from source.  I have 1.0.rc1
source code.

While running configure, I noticed that configure checks for `sys/bittypes.h'.
I believe that's a typo, and should be sys/bitypes.h.  I know of no UNIX system
(and I have access to OSF/1, Solaris, HP-UX, AIX, IRIX, Linux, and FreeBSD) that
has a sys/bittypes.h, but OSF/1 has sys/bitypes.h, and any system that has BIND
8.x header files will have a sys/bitypes.h somewhere.

sys/bitypes.h is useful on OSF/1 because that's where many of the typedefs are
for the "sized" types, e.g. u_int8_t, int8_t, u_int32_t, int32_t, etc.
Yep, that's a typo.  

-AC_CHECK_HEADERS(sys/bittypes.h memory.h unistd.h)
+AC_CHECK_HEADERS(sys/bitypes.h memory.h unistd.h)
Blocks: 134348
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → mozilla1.0
r=bryner
Keywords: mozilla1.0
Whiteboard: [fixed on trunk]
Blocks: 138348
No longer blocks: 134348
Whiteboard: [fixed on trunk] → [fixed on trunk][drivers queue]
Target Milestone: mozilla1.0 → mozilla1.0.1
http://mpt.phrasewise.com/2002/06/07
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: [fixed on trunk][drivers queue]
Target Milestone: mozilla1.0.1 → mozilla1.1alpha
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.