Closed Bug 1399036 Opened 3 years ago Closed 3 years ago

Enable date/time input by default on all builds

Categories

(Core :: Layout: Form Controls, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: jessica, Assigned: jessica)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

We plan to ship this in Firefox v57.
Attached patch patch.Splinter Review
We got the pre-beta signoff report with green light from QA, yay!
Attachment #8907636 - Flags: review?(mconley)
Comment on attachment 8907636 [details] [diff] [review]
patch.

Review of attachment 8907636 [details] [diff] [review]:
-----------------------------------------------------------------

\o/!! Great job, everyone!
Attachment #8907636 - Flags: review?(mconley) → review+
Pushed by jjong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2769237547ba
Enable date/time input by default on all builds. r=mconley
https://hg.mozilla.org/mozilla-central/rev/2769237547ba
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Thanks for updating the pages!
Hi Jessica,
Here are my observations about this feature:
1. In case of partially filled date, validity state's badInput is not getting set to true.
2. when clear button is clicked and user clicks outside, in that case blur event of input control is not getting fired. 
I will report these bugs. I know this feature is in development stage.
(In reply to Parthiv Shah from comment #9)
> Hi Jessica,
> Here are my observations about this feature:
> 1. In case of partially filled date, validity state's badInput is not
> getting set to true.
> 2. when clear button is clicked and user clicks outside, in that case blur
> event of input control is not getting fired. 
> I will report these bugs. I know this feature is in development stage.

Thanks for reporting these issues.
For 1, validity state can only be verified when a valid date/time is set in .value, if date is not complete, we can't verify its validity.
For 2, I could not reproduce it on Nightly macOS.

But, please, do file separate bugs for better tracking. Thanks again.
Hi Jessica,
Thank you for your reply. 
For 1, in webkit (chrome) validity state's badInput is set to true in case of partially filled date. Is there any way in Firefox to distinguish between partially filled date and empty date as my validation relies on this.
For 2, Did you fill the date and clear the date using X button? I am able reproduce it on Firefox 57 (64 bit) and Developer Edition 58.0b7 (64-bit).

I have filed separate bugs (Bug 1421555 and Bug 1421558) for better tracking. I have attached demo files so that you can test it and let me know if it is reproducible or not.

Thanks Again Jessica.
You need to log in before you can comment on or make changes to this bug.