Make browserSettings an optional permission

VERIFIED FIXED in mozilla57

Status

P3
normal
VERIFIED FIXED
a year ago
4 months ago

People

(Reporter: bsilverberg, Assigned: bsilverberg)

Tracking

({dev-doc-complete})

unspecified
mozilla57
dev-doc-complete

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [browserSettings] triaged)

Attachments

(1 attachment)

(Assignee)

Description

a year ago
As discussed in bug 1322308, browserSettings would be convenient to have as an optional permission, as opposed to a required permission. This bug is to implement that change.
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8907145 [details]
Bug 1399176 - Make browserSettings an optional permission,

https://reviewboard.mozilla.org/r/178834/#review183874
Attachment #8907145 - Flags: review?(mixedpuppy) → review+
(Assignee)

Updated

a year ago
Keywords: dev-doc-needed

Comment 3

a year ago
Pushed by bsilverberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/777f90a6648b
Make browserSettings an optional permission, r=mixedpuppy
https://hg.mozilla.org/mozilla-central/rev/777f90a6648b
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
I think this is only a matter of adding it here, yes?
https://developer.mozilla.org/en-US/Add-ons/WebExtensions/manifest.json/optional_permissions

(I mean, it should still be listed in https://developer.mozilla.org/en-US/Add-ons/WebExtensions/manifest.json/permissions.)
Flags: needinfo?(bob.silverberg)
(Assignee)

Comment 6

a year ago
Looks good Will. Should browserSettings also be added to the compatibility tables for both of those pages?
Flags: needinfo?(bob.silverberg)
Thanks Bob.

I don't add API permissions to the compat tables, because it seems redundant: if a browser supports a permission-protected API, it will support the permission. If it doesn't it won't. Does that sound reasonable? I could add a note to that effect in the browser compat section, just in case anyone's wondering.
Keywords: dev-doc-needed → dev-doc-complete

Comment 8

a year ago
I can reproduce this issue on Firefox 56.0.2 (20171024165158) under Wind 10 64-bit. 

This issue is verified as fixed on Firefox 57.0b14 (20171102181127), Firefox 58.0a1 (20171102100041) under Wind 10 64-bit and Mac OS X 10.13.

Updated

a year ago
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified

Updated

4 months ago
Product: Toolkit → WebExtensions

Comment 9

4 months ago
Update for MDN compatibility table needs merging:
https://github.com/mdn/browser-compat-data/pull/2407
(if somebody has time and permissions)

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/manifest.json/optional_permissions#Browser_compatibility
status-firefox57: verified → ---
You need to log in before you can comment on or make changes to this bug.