Closed Bug 1399269 Opened 2 years ago Closed 2 years ago

Remove AppState from the app.

Categories

(Firefox for iOS :: Browser, enhancement, P1)

Other
iOS
enhancement

Tracking

()

RESOLVED FIXED
Iteration:
1.30
Tracking Status
fxios 10.0 ---

People

(Reporter: farhan, Assigned: farhan)

References

Details

(Whiteboard: [Photon][MobileCore])

Attachments

(1 file)

The AppState object was a concept used to keep the old Menu in sync. We've removed the old menu and no longer need the AppState to help keep the menu in sync. 

The new menu no longer has as much state as the old one. Actions that are relevant to the page only show up in a separate menu.

Because of this lets get rid of the appstate concept completely.
Attached file Pull Request
Attachment #8907316 - Flags: review?(jhugman)
Comment on attachment 8907316 [details]
Pull Request

Sad panda. :(

There are a lot of whitespace fixes in this PR. Should we consider swiftfmt again?
Attachment #8907316 - Flags: review?(jhugman) → review+
Duplicate of this bug: 1393308
https://github.com/mozilla-mobile/firefox-ios/commit/72071c60ceac00b8134564b566268f86c9e33910
Assignee: nobody → fpatel
Status: NEW → RESOLVED
Iteration: --- → 1.30
Closed: 2 years ago
Priority: -- → P1
Resolution: --- → FIXED
Whiteboard: [Photon] → [Photon][MobileCore]
You need to log in before you can comment on or make changes to this bug.