Closed Bug 1399278 Opened 7 years ago Closed 7 years ago

wr-text: small emoji?

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox57 --- affected

People

(Reporter: Gankra, Assigned: Gankra)

References

Details

(Whiteboard: [wr-reserve] [gfx-noted])

Attachments

(4 files)

Attached image emoji.png
Dunno why this is, but some emoji are showing up small? Possibly only in text-emphasis marks? I thought it used to be all emoji, but emoji in normal text look fine now? Confused.
Could you attach the testcase used to create your screenshot, please?
test-case:

<body style="max-width: 40em; font-family: sans-serif">

<p> TIRED: 
Attached file emoji.html
Oops, here's the test-case properly
Also just to be clear, this is a webrendest layers-free bug.

My only theory right now is that webrender should be doing some kind of special "emoji text snapping"?
Attachment #8907333 - Attachment mime type: text/plain → text/html
FWIW, the rendering I see in Nightly (with webrender disabled, according to about:config settings) matches the right-hand version in your screenshot (i.e. with the smaller version of the text-emphasis glyphs).

How does the sizing compare to regular ASCII letters used in text-emphasis? In my testing, I think the emoji sizing in text-emphasis matches the sizing of other text (i.e. both Latin letters and emoji glyphs match the smaller version of your screenshot.
Component: Graphics: Text → Graphics: WebRender
Whiteboard: [gfx-noted][wr-mvp][triage]
I'm only seeing this on macos, so I think this might be another consequence of https://bugzilla.mozilla.org/show_bug.cgi?id=1397458
Attached image emoj-n-T.png
Here's a screen shot with capital T's next to it for comparison. (macos)

Left: vanilla nightly gecko
Right: webrendest + layers-free
Curious... what I see (with vanilla Nightly, macOS) looks to me much more like the right-hand version in your screenshot.
Maybe there's a minimum font size configured in one of the Firefox profiles?
https://gankro.github.io/blah/webtests/text.html has this case at the top, for anyone who wants to test this out.
Priority: -- → P2
Whiteboard: [gfx-noted][wr-mvp][triage] → [wr-mvp] [gfx-noted]
(In reply to Markus Stange [:mstange] from comment #9)
> Maybe there's a minimum font size configured in one of the Firefox profiles?

I don't believe text-decoration glyphs are constrained by the font.minimum-size.* prefs, as they are required to be smaller than the text to which they're applied.
I can also reproduce the sizing difference, on today's nightly, with default settings vs webrendest+layers-free on a HiDPI Mac.
Blocks: 1407627
Summary: text-layers: small emoji? → wr-text: small emoji?
Priority: P2 → P3
Whiteboard: [wr-mvp] [gfx-noted] → [wr-reserve] [gfx-noted]
Assignee: nobody → a.beingessner
This seems to have resolved itself. I expect because we're using CoreText a lot more now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: